PowerProtect Data Manager — Перенастройка единого входа OKTA после модернизации

Summary: Единый вход OKTA не работает после обновления PowerProtect Data Manager с 19.13 до 19.14. Исправление применено к PowerProtect Data Manager 19.13 как (PPDMESC-3304)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

aaa.log:

./aaa.2023-08-23.0.log.gz:org.springframework.security.oauth2.jwt.JwtException: An error occurred while attempting to decode the Jwt: Signed JWT rejected: Another algorithm expected, or no matching keys found

 

Cause

Ошибка в aaa.log:

2023-08-24T07:39:26.964Z ERROR [] [https-jsse-nio-9090-exec-1] [][][][TRACE_ID:97d2704ca1652f50][] [c.e.b.a.s.s.DefaultSsoService.lambda$1(71)] - SSO login issue: {}
org.springframework.security.oauth2.jwt.JwtException: An error occurred while attempting to decode the Jwt: Signed JWT rejected: Another algorithm expected, or no matching keys found

Это означает, что AAA ожидает HS256, который является его идентификатором по умолчанию, но OKTA всегда возвращает подпись RS256.

 

Resolution

  • Вход в PowerProtect Data Manager ssh
  • cd /usr/local/brs/lib/aaa/config
  • vim application-sso.properties
  • Проверьте, является ли переменная aaa.sso.client.alg=RS256, если нет, то измените HS256 на RS256.
  • Выйдите из vim (:wq!)
  • Перезапуск AAA

 

Article Properties
Article Number: 000218197
Article Type: Solution
Last Modified: 18 Mar 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.