PowerProtect Data Manager - Yükseltmeden sonra OKTA SSO'yu yeniden yapılandırma

Summary: OKTA SSO, 19.13'ten 19.14'e PowerProtect Data Manager Güncelleştirmesinden sonra çalışmıyor. Düzeltme, PowerProtect Data Manager 19.13 e şu şekilde uygulanır: (PPDMESC-3304)

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Symptoms

aaa.log:

./aaa.2023-08-23.0.log.gz:org.springframework.security.oauth2.jwt.JwtException: An error occurred while attempting to decode the Jwt: Signed JWT rejected: Another algorithm expected, or no matching keys found

 

Cause

aaa.log'daki hata:

2023-08-24T07:39:26.964Z ERROR [] [https-jsse-nio-9090-exec-1] [][][][TRACE_ID:97d2704ca1652f50][] [c.e.b.a.s.s.DefaultSsoService.lambda$1(71)] - SSO login issue: {}
org.springframework.security.oauth2.jwt.JwtException: An error occurred while attempting to decode the Jwt: Signed JWT rejected: Another algorithm expected, or no matching keys found

Bu, AAA'nın varsayılan olan HS256'yı beklediği anlamına gelir, ancak OKTA her zaman bir RS256 imzası döndürür.

 

Resolution

  • PowerProtect Data Manager SSH de oturum açın
  • cd /usr/local/brs/lib/aaa/config
  • vim application-sso.properties
  • Değişkenin aaa.sso.client.alg=RS256 olup olmadığını kontrol edin, aksi takdirde HS256'dan RS256'ya değiştirin.
  • Vim'den çık (:wq!)
  • AAA Yeniden Başlatma

 

Article Properties
Article Number: 000218197
Article Type: Solution
Last Modified: 18 Mar 2025
Version:  1
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