NVP vProxy: Red Hat 9 VM does not show some folders during an FLR.

Summary: A Virtual Machine (VM) File Level Restore (FLR) is performed on a Red Hat 9.x VM. The mount operation is successful but some folders are not seen during the FLR browse operation. No error is reported in the user interface. The VM is configured with LVM partitions. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • The NetWorker VMware solution is configured with the NetWorker VMware Protection (NVP) vProxy appliance.
  • A File Level Restore (FLR) is performed for a Linux VM. The FLR mount operation completes successfully; however, during the browse operation only some of the system folders are presented:
FLR browse only listing grub and boot directories
NOTE: In this example, the browse session is only showing /boot and /bootefi directories. The / (root) and /home folders and their contents are missing.
  • The issue appears regardless of using the NetWorker Management Console (NMC) or NetWorker Web User Interface (NWUI), and when the VM's root user account is used to perform the FLR mount.
  • The VM's /opt/emc/vproxyra/logs/vflragentd/vflragentd-agent.log reports:
YYYY-MM-DDTHH:mm:SS-TZ INFO:   Mount #6: HH:mm:SS Mounting LVM volumes...
YYYY-MM-DDTHH:mm:SS-TZ INFO:   Mount #6: HH:mm:SS Running command: /sbin/lvm pvs --config 'global { use_lvmetad = 0 }' -o vg_name,pv_name --noheadings --separator : '/dev/sdc3' 2>&1
YYYY-MM-DDTHH:mm:SS-TZ INFO:   Mount #6: HH:mm:SS -->   Cannot use /dev/sdc3: device is not in devices file
  • The VM is a Red Hat 9.x release (or later)
  • The VM's LVM configuration meet FLR support requirements: NVP vProxy: FLR LVM Limitations
  • The vProxy appliance is 4.3.0-38 or older.

Cause

The VM is configured with LVM partitions. Code changes were needed in the vProxy to support Red Hat 9 Logical Volume Management (LVM) devices.

Code changes went into vProxy 4.3.0-39 which resolve this issue.

Resolution

  1. Ensure that the VM's LVM configuration is supported by vProxy FLR: NVP vProxy: FLR LVM Limitations
  2. If the current vProxies are 4.3.0-38 or older, upgrade the vProxy appliances:
NOTE: It is recommended to upgrade the vProxy appliance to the latest release supported by your NetWorker server. vProxy support is detailed in the NetWorker version-specific compatibility guides: https://elabnavigator.dell.com/eln/modernHomeAutomatedTiles?page=NetWorker
  1. Once the vProxy has been upgraded to 4.3.0-39 or newer, perform the FLR again, the LVM partitions are visible during the browse operations.

Additional Information

The Linux lsblk command can be used to identify which file system mountpoints use LVM devices.

[root@lnx-client03]:~# lsblk
NAME          MAJ:MIN RM  SIZE RO TYPE MOUNTPOINTS
sda             8:0    0   30G  0 disk
├─sda1          8:1    0  600M  0 part /boot/efi
├─sda2          8:2    0    1G  0 part /boot
└─sda3          8:3    0 28.4G  0 part
  ├─rhel-root 253:0    0 25.4G  0 lvm  /
  └─rhel-swap 253:1    0    3G  0 lvm  [SWAP]
sr0            11:0    1 1024M  0 rom

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000219868
Article Type: Solution
Last Modified: 28 Mar 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.