PowerFlex 4.X: MDS-systemer viser Tom

Summary: Denne artikel gennemgår løsning af lagerproblemer i MDS Powerflex-systemet, der skyldes manglende MDM IP-adresser, som angivet i MDS kubectl-logfiler og LIA-logfiler på MDM er.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • MDS Powerflex-systemlager vises ikke.
  • MDS kubectl-logfiler viser en 404-fejl, når du forsøger at hente MdmIps fra LCM Manager, og angiver, at mdm.ip.addresses mangler og kan ikke oprette forbindelse til klyngen.
23:21:28.383 [|https-openssl-nio-443-exec-4] INFO  c.e.s.s.services.GeneralServiceImp - Can't fetch MdmIps from LCM manager at https://thin-deployer:9433/asm/device/mdm_cluster_info?certname=scaleio-block-legacy-gateway-mds. Request returned response code 404, respons
e message: Not Found
23:21:28.383 [|https-openssl-nio-443-exec-4] ERROR c.e.s.s.services.GeneralServiceImp - mdm.ip.addresses is missing
23:21:28.383 [|https-openssl-nio-443-exec-4] INFO  c.e.s.s.services.GeneralServiceImp - Got Cluster IPs
23:21:28.383 [|https-openssl-nio-443-exec-4] ERROR c.e.s.s.s.ConnectionServiceImpl - Failed connecting to cluster
23:21:28.383 [|https-openssl-nio-443-exec-4] ERROR c.e.s.s.r.SystemRepositoryImpl -
com.emc.s3g.scaleio.common.gateway.ScaleIORemoteRuntimeException: Failed connecting to cluster: no MDM IP is set
  • LIA-logfiler på MDM'er indikerer fejl i kørslen scli --reset_management_trust, sandsynligvis på grund af mgmt_ca.pem certifikatet føjes ikke til MDM Truststore.
2024/01/03 18:06:18.061168 MED:7f905831bdb0:liaCmd_ResetMgmtTrust:05502: Executing command : scli --reset_management_trust --mdm_port
 8611 --i_am_sure
2024/01/03 18:06:18.377107 LOW:7f905831bdb0:liaCmd_ResetMgmtTrust:05508: Run command [scli --reset_management_trust --mdm_port 8611 -
-i_am_sure] returned Value: 1 [0-is success]
2024/01/03 18:06:18.377119 LOW:7f905831bdb0:liaCmd_ResetMgmtTrust:05539: MDM Reset Security command failed, cmdRc = 1

Cause

Den grundlæggende årsag til lagerproblemet i MDS Powerflex-systemet er forkert opsætning af de nødvendige certifikater inden importprocessen. Ikonet mgmt_ca.pem Certifikatet skal især være korrekt oprettet i MDM-tillidslageret for at sikre vellykket hentning af MDM-IP-adresser under importen. Manglende genkendelse af dette certifikat medfører forbindelsesproblemer og efterfølgende lagerproblemer.

Resolution

1 – Kontroller MDM-konfigurationsfiler:

Gå til.

/opt/emc/scaleio/mdm/cfg 

Og angiv certifikaterne for at sikre, at de genereres.

Kontrollér tilstedeværelsen af mgmt_ca.pem-certifikatet og de sidste par tegn. 2 – Opdater CLI Trust Store:

cat /root/.scli/cli_truststore.pem

Hvis mgmt_ca.pem-certifikatet ikke findes i CLI-tillidslageret, skal du tilføje det med.

scli --add_certificate --certificate_file /opt/emc/scaleio/mdm/cfg/mgmt_ca.pem.

3- Spred certifikatet på tværs af MDM'er:

Sørg for, at mgmt_ca. PEM-certifikatet findes på alle MDM'er, undtagen tiebreakeren.

4 – Fjern og tilføj MDS-gateway igen:

Fra ressourcesiden skal du midlertidigt fjerne MDS-gatewayen til fejlfinding. 

5- Backup-certifikater:

Opret sikkerhedskopier af mgmt_ca.pem og mdm_mno_certificate.pem ved hjælp af cp-kommandoen.

cp mgmt_ca.pem mgmt_ca.pem.bk
cp mdm_mno_certificate.pem mdm_mno_certificate.pem.bk

6 – Genopdag MDS:

Når alle trin er fuldført, skal du genopdage MDS for at GENETABLERE korrekt systemfunktionalitet.

Affected Products

PowerFlex appliance R640

Products

PowerFlex rack, VxFlex Ready Nodes, PowerFlex custom node, PowerFlex appliance R650, PowerFlex appliance R6525, PowerFlex appliance R660, PowerFlex appliance R6625, Powerflex appliance R750, PowerFlex appliance R760, PowerFlex appliance R7625 , PowerFlex custom node, PowerFlex custom node R650, PowerFlex custom node R6525, PowerFlex custom node R660, PowerFlex custom node R6625, PowerFlex custom node R750, PowerFlex custom node R760, PowerFlex custom node R7625, PowerFlex appliance R740XD, PowerFlex appliance R7525, PowerFlex appliance R840 ...
Article Properties
Article Number: 000220860
Article Type: Solution
Last Modified: 29 Dec 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.