PowerFlex 4.X: Systemy MDS pokazują puste
Summary: Ten artykuł zawiera wskazówki dotyczące rozwiązywania problemów z zapasami w systemie MDS Powerflex spowodowanych brakiem adresów IP MDM, na co wskazują dzienniki kubectl MDS i dzienniki LIA w MDM. ...
Symptoms
- Nie wyświetla się inwentaryzacja systemu MDS Powerflex.
- Dzienniki kubectl MDS pokazują błąd 404 podczas próby pobrania MdmIps z menedżera LCM, stwierdzając, że
mdm.ip.addressesbrakuje klastra i nie można nawiązać połączenia z klastrem.
23:21:28.383 [|https-openssl-nio-443-exec-4] INFO c.e.s.s.services.GeneralServiceImp - Can't fetch MdmIps from LCM manager at https://thin-deployer:9433/asm/device/mdm_cluster_info?certname=scaleio-block-legacy-gateway-mds. Request returned response code 404, respons e message: Not Found 23:21:28.383 [|https-openssl-nio-443-exec-4] ERROR c.e.s.s.services.GeneralServiceImp - mdm.ip.addresses is missing 23:21:28.383 [|https-openssl-nio-443-exec-4] INFO c.e.s.s.services.GeneralServiceImp - Got Cluster IPs 23:21:28.383 [|https-openssl-nio-443-exec-4] ERROR c.e.s.s.s.ConnectionServiceImpl - Failed connecting to cluster 23:21:28.383 [|https-openssl-nio-443-exec-4] ERROR c.e.s.s.r.SystemRepositoryImpl - com.emc.s3g.scaleio.common.gateway.ScaleIORemoteRuntimeException: Failed connecting to cluster: no MDM IP is set
- Dzienniki LIA na MDM wskazują niepowodzenie uruchamiania
scli --reset_management_trust, prawdopodobnie ze względu namgmt_ca.pemcertyfikat nie jest dodawany do magazynu zaufanych rozwiązań MDM.
2024/01/03 18:06:18.061168 MED:7f905831bdb0:liaCmd_ResetMgmtTrust:05502: Executing command : scli --reset_management_trust --mdm_port 8611 --i_am_sure 2024/01/03 18:06:18.377107 LOW:7f905831bdb0:liaCmd_ResetMgmtTrust:05508: Run command [scli --reset_management_trust --mdm_port 8611 - -i_am_sure] returned Value: 1 [0-is success] 2024/01/03 18:06:18.377119 LOW:7f905831bdb0:liaCmd_ResetMgmtTrust:05539: MDM Reset Security command failed, cmdRc = 1
Cause
mgmt_ca.pem W szczególności certyfikat musi być poprawnie ustanowiony w magazynie zaufanych certyfikatów MDM, aby zapewnić pomyślne pobranie adresu IP MDM podczas importu. Nierozpoznanie tego certyfikatu prowadzi do problemów z łącznością i późniejszych problemów z inwentaryzacją.Resolution
1. Sprawdź pliki konfiguracyjne MDM:
Przejdź do.
/opt/emc/scaleio/mdm/cfg
I wyświetl listę certyfikatów, aby upewnić się, że zostały wygenerowane.
Sprawdź obecność certyfikatu mgmt_ca.PEM i kilka ostatnich znaków. 2. Zaktualizuj magazyn zaufania CLI:
cat /root/.scli/cli_truststore.pem
Jeśli certyfikat mgmt_ca.pem nie zostanie znaleziony w magazynie zaufanych certyfikatów interfejsu wiersza poleceń, dodaj go za pomocą.
scli --add_certificate --certificate_file /opt/emc/scaleio/mdm/cfg/mgmt_ca.pem.
3. Rozłóż certyfikat na MDM:
Upewnij się, że mgmt_ca. Certyfikat PEM jest obecny we wszystkich MDM, z wyjątkiem tiebreakera.
4. Usuń i ponownie dodaj bramkę MDS:
Na stronie zasobów tymczasowo usuń bramkę MDS w celu rozwiązania problemu.
5. Certyfikaty zapasowe:
Utwórz kopie zapasowe plików mgmt_ca.pem i mdm_mno_certificate.pem za pomocą polecenia cp.
cp mgmt_ca.pem mgmt_ca.pem.bk cp mdm_mno_certificate.pem mdm_mno_certificate.pem.bk
6. Odkryj na nowo MDS:
Po wykonaniu wszystkich czynności należy ponownie wykryć MDS, aby przywrócić prawidłowe działanie systemu.