NVE:アプライアンスにインストールされているバイナリ バージョンが、インストールされているアップグレードまたはロールアップ バージョンと一致しません

Summary: NVE(NetWorker Virtual Edition)アプライアンスにインストールされているバイナリのバージョンが、インストールされているアップグレード パッケージまたはロールアップ パッケージに組み込まれているバイナリーのバージョンと一致しません。

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Symptoms

  • NetWorker Virtual Editionアプライアンス(NVE)が導入され、正常に実行されます。
  • いくつかのNveUpgradeおよびNvePlatformOsRollupパッケージがインストールされています。
  • NetWorker Installation Managerユーザー インターフェイスには、すべてのNveUpgradeおよびNvePlatformOsRollupパッケージが完了として表示されます。 
  • 次のコマンドは、すべてのアップデートが完了したことを示します。
 [avi-cli --verbose localhost --password 'xxxxxxxx' --listhistory]
  • システムは、各アップデート後も正常に機能し続けます。 
  • バイナリのバージョンを確認すると、NveUpgreadeおよびNvePlatformOsRollupパッケージのバージョンが有効になっていないことが確認されます。 
  • NVEは、次のコマンドで証明できるように、バイナリのバージョンをベース インストールとして表示します。
[rpm -qa |grep <binary_name>]
rpm -qa | grep kernel
displays 4.12.14-122.12.1.x86_64: While it should be 4.12.14-122.173.1.x86_64 which was embedded in the latest Rollup.

rpm -qa | grep sqlite3
displays 3.8.10.2-9.15.1.x86_64: While it should be 3.39.3-9.26.1.x86_64 which was embedded in the latest Rollup.

rpm -qa | grep openssl
displays 1.0.2p-3.14.1.x86_64: While it should be 1_1-1.1.1d-2.98.1.x86_64 which was embedded in the latest Rollup.

Cause

さらに調査を進めると、err.logで次のエラー メッセージが報告されていることが判明しました。

Path to err.log:

/space/avamar/var/avi/server_data/package_data/NvePlatformOsRollup_2023-R3-v4.avp_xxxxxxxxxx err.log

次のコマンドは、アップデート プロセス中に実行され、コマンドの出力から現在のカーネルのバージョンを取得します。

[uname -a] 

YYYY-MM-DD HH:mm:SS (-TZ) 47198950636200 ERROR: "ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no root@<NVE_IP_Address> uname -a", exit status=255 (error)

exit status=255 (error)」というエラーが出るので、アップグレードワークフローが成功しても、OsRollup のパッケージ (ほとんどが基本オペレーティングシステムパッケージで構成される) はアップグレードされません

この誤動作の根本原因は、ローカル ホストの PermitRootLogin 値が既定値 の "yes" から 誤った値の "no " に変更されていることです。この設定ミスにより、SSHコマンド(上記)でインストールされているカーネルのバージョンを表示できませんでした。

LogLevel INFO
kexalgorithms ecdh-sha2-nistp384,ecdh-sha2-nistp521
MACs hmac-sha2-512-etm@openssh.com,hmac-sha2-512,hmac-sha2-256-etm@openssh.com,hmac-sha2-256,umac-128-etm@openssh.com,umac-128@openssh.com
PermitEmptyPasswords no
PermitRootLogin no
Match Address ::1,127.0.0.1,127.0.0.1,127.0.0.2,::1,<NVE_IPv4_Address>,<NVE_IPv6_Address>
PermitRootLogin no

Resolution

この問題に対処するには、次の手順を実行します。

  1. /etc/ssh/sshd_configファイルをデフォルトの形式に変更します。変更は 1 行のみで、終了セクションを次のように変更する必要があります。
LogLevel INFO
kexalgorithms ecdh-sha2-nistp384,ecdh-sha2-nistp521
MACs hmac-sha2-512-etm@openssh.com,hmac-sha2-512,hmac-sha2-256-etm@openssh.com,hmac-sha2-256,umac-128-etm@openssh.com,umac-128@openssh.com
PermitEmptyPasswords no
PermitRootLogin no
Match Address ::1,127.0.0.1,127.0.0.1,127.0.0.2,::1,<NVE_IPv4_Address>,<NVE_IPv6_Address>
PermitRootLogin yes
メモ: 「Match Address」行の後のPermitRootLoginエントリーを「yes」に設定する必要があります。NVEの正しいIPv4/IPv6アドレスを「Match Address」行に定義する必要があります。PermitRootLogin 情報の詳細については、次を参照してください。NVE:NetWorker Virtual Editionでroot SSHアクセスを許可する方法
  1. 上記の変更が完了したら、 NVEを再起動します
  2. 次のコマンドを実行して、カーネルのバージョンを表示します
ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no root@<NVE_IP_ADDRESS> uname -a
予想される出力は次のようになります。
nve:~ # ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no root@<NVE_IP_ADDRESS> uname -a
Linux nve 4.12.14-122.153-default #1 SMP Tue Mar 7 14:13:19 UTC 2023 (9f7af45) x86_64 x86_64 x86_64 GNU/Linux
  1. 最新のNveUpgreadeまたはNvePlatformOsRollupパッケージを適用して、バイナリのバージョンを最新バージョンに更新します。
  2. 以下のコマンドを使用して、インストールされているバイナリのバージョンを確認し、適用されたNveUpgreadeまたはNvePlatformOsRollupパッケージのバージョンと比較します。
[rpm -qa]

Additional Information

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000221296
Article Type: Solution
Last Modified: 14 Aug 2025
Version:  7
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