A IU da Web do OpenManage Server Administrator falha ao carregar nos servidores quando o nome do host tem um sublinhado
Summary: Instruções para restaurar o acesso à interface Web do OpenManage Server Administrator (OMSA) em um servidor com um sublinhado em seu nome de host
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Symptoms
A interface Web do OpenManage Server Administrator (OMSA) está inacessível em um servidor onde o nome do host contém um sublinhado. Por exemplo, o nome do host do servidor é "FS_1.domain.local". A mensagem recebida geralmente é "This site can't be reached" or "ERR_CONNECTION_CLOSED." O serviço DSM SA Connection está em execução e monitorando as conexões na porta 1311 conforme esperado.
Cause
Sublinhados não são um caractere válido para nomes de host DNS (Sistema de Nomes de Domínio), conforme documentado em RFC 1912.
https://datatracker.ietf.org/doc/html/rfc1912#section-2.1Como resultado, o OMSA não consegue gerar um certificado autoassinado durante a instalação e inicia seus serviços sem uma configuração TLS válida. O serviço de conexão ainda é executado e se vincula à porta 1311 durante a inicialização, mas não aceita conexões.
https://datatracker.ietf.org/doc/html/rfc1912#section-2.1Como resultado, o OMSA não consegue gerar um certificado autoassinado durante a instalação e inicia seus serviços sem uma configuração TLS válida. O serviço de conexão ainda é executado e se vincula à porta 1311 durante a inicialização, mas não aceita conexões.
Resolution
Opção A
Altere o nome do servidor para um novo nome que contenha apenas letras, números ou hífens e, em seguida, desinstale e reinstale o OMSA.
Opção B
Instale um certificado válido e acesse o OMSA por endereço IP em vez de por nome de host. A execução do seguinte comando OMConfig no servidor afetado cria um novo certificado autoassinado:
Substitua "<servername>" por qualquer valor compatível. A opção mais simples é usar o nome atual do servidor com quaisquer sublinhados removidos.
Altere o nome do servidor para um novo nome que contenha apenas letras, números ou hífens e, em seguida, desinstale e reinstale o OMSA.
Opção B
Instale um certificado válido e acesse o OMSA por endereço IP em vez de por nome de host. A execução do seguinte comando OMConfig no servidor afetado cria um novo certificado autoassinado:
omconfig preferences webserver attribute=gennewcert cn=<servername> org=Dell ou=ESG location=RoundRock state=TX country=US validity=3650 keysize=2048 algorithm=SHA512 webserverrestart=true
Substitua "<servername>" por qualquer valor compatível. A opção mais simples é usar o nome atual do servidor com quaisquer sublinhados removidos.
Affected Products
OpenManage Server AdministratorArticle Properties
Article Number: 000221443
Article Type: Solution
Last Modified: 10 Apr 2025
Version: 4
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