PowerFlex 4.Xファームウェア アップデートがUS-ASCIIの無効なバイト シーケンスで失敗する

Summary: US-ASCIIの無効なバイト シーケンスによりファームウェア アップデートが失敗する。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

シナリオ

クラスターで、リソース グループを使用して実行されたファームウェアのアップグレードが行われていました。

現象

ジョブIDからのdeployment.logは、ファームウェア アップデートが失敗し、プレイブックが実行されていることをレポートします。プレイブックのコマンドは、「/usr/sbin/sysctl -p」を実行するように設定されていることに注意してください。

ERROR [2024-01-25T20:21:33.358478] 25824: service_deployment.rb:6084:in `process_firmware_update': Encountered an error during firmware update: ArgumentError: invalid byte sequence in US-ASCII
["org/jruby/RubyString.java:4727:in `scan'", "/opt/asm-deployer/lib/asm/provider/elementmanager/scaleio.rb:9762:in `update_sysctl_parameter'", "/opt/asm-deployer/lib/asm/service_deployment.rb:5909:in `block in process_firmware_update'", "org/jruby/RubyArray.java:1865:in `each'", "/opt/asm-deployer/lib/asm/service_deployment.rb:5731:in `process_firmware_update'", "/opt/asm-deployer/lib/asm/service_deployment.rb:504:in `process'", "/opt/asm-deployer/lib/asm.rb:369:in `block in process_deployment'", "org/jruby/RubyArray.java:1907:in `each_slice'", "/opt/asm-deployer/lib/asm.rb:351:in `block in process_deployment'", "/opt/dependencies/dell-asm-util/lib/asm/util.rb:22:in `block in execute_async'"]
...
INFO  [2024-01-25T20:22:45.017056] 25824: service_deployment.rb:1795:in `process_ansible_playbook': Starting processing playbook: [{"hosts"=>"all", "become"=>true, "vars"=>{"overcommit_ratio"=>100, "overcommit_memory"=>2}, "tasks"=>[{"name"=>"Replace unvalid values in sysctl conf", "replace"=>{"path"=>"/etc/sysctl.conf", "regexp"=>"^net.ipv4.conf.(ens192.log_martians.*)$", "replace"=>"#net.ipv4.conf.\\1 # PFXM REMOVED INVALID OPTION"}}, {"name"=>"Replace unvalid values in sysctl conf", "replace"=>{"path"=>"/etc/sysctl.conf", "regexp"=>"^net.ipv4.conf.(ens32.log_martians.*)$", "replace"=>"#net.ipv4.conf.\\1 # PFXM REMOVED INVALID OPTION"}}, {"name"=>"update threshold1", "ansible.posix.sysctl"=>{"name"=>"net.ipv4.neigh.default.gc_thresh1", "value"=>8192}}, {"name"=>"update threshold2", "ansible.posix.sysctl"=>{"name"=>"net.ipv4.neigh.default.gc_thresh2", "value"=>16384}}, {"name"=>"update threshold3", "ansible.posix.sysctl"=>{"name"=>"net.ipv4.neigh.default.gc_thresh3", "value"=>32768}}, {"name"=>"Update overcommit ratio for SDS", "ansible.posix.sysctl"=>{"name"=>"vm.overcommit_ratio", "value"=>"{{ overcommit_ratio }}"}}, {"name"=>"Update overcommit_memory ratio for SDS", "ansible.posix.sysctl"=>{"name"=>"vm.overcommit_memory", "value"=>"{{ overcommit_memory }}"}}, {"name"=>"Apply sysctl changes", "command"=>{"argv"=>["
]}}]}] with inventory:

...ノードで直接コマンドを実行すると、次のエラーが表示されることがあります。

[root@node3 etc]# /usr/sbin/sysctl -p
...
sysctl: /etc/sysctl.conf(91): invalid syntax, continuing...

 

問題

影響を受けるノードでは、ファームウェア アップデートを続行できません。

Cause

根本的な原因

この問題は、sysctl.confファイル内の非ASCII文字または特殊文字に起因します。これは、sysctl処理中に使用される予定のUS-ASCII文字エンコーディングと互換性がありません。システムが sysctl.conf から設定を読み取って適用しようとすると、この無効な文字シーケンスが発生し、「US-ASCII の無効なバイトシーケンス」エラーが発生します。このキャラクターが含まれている具体的な理由は不明のままです。 

Resolution

対策

1- 影響を受けるノードの元のsysctl.confファイルをバックアップします。

 cp /etc/sysctl.conf /etc/sysctl.conf.backup

2- 正常に機能していることが確認されているノードからsysctl.confファイルをコピーします。

 scp /etc/sysctl.conf root@:/etc/sysctl.conf

3- 影響を受けるノードに新しい構成を適用します。

 /usr/sbin/sysctl -p

4- コマンドが「無効な構文」エラーなしで正常に完了することを確認します。

5 - 上記の手順を完了して確認したら、リソース グループを使用してファームウェア アップデート プロセスを再開します。

 

問題が発生するバージョン 

PFxM 4.5.1.1以下

修正バージョン

PFxM 4.5.2

Affected Products

PowerFlex rack, VxFlex Ready Nodes, PowerFlex custom node, PowerFlex appliance connectivity, PowerFlex appliance R650, PowerFlex appliance R6525, PowerFlex appliance R660, PowerFlex appliance R6625, Powerflex appliance R750, PowerFlex appliance R760 , PowerFlex appliance R7625, PowerFlex appliance R640, PowerFlex appliance R740XD, PowerFlex appliance R7525, PowerFlex appliance R840 ...
Article Properties
Article Number: 000221574
Article Type: Solution
Last Modified: 10 Feb 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.