OpenManage Entreprise : OMEVV peut ne pas réussir à enregistrer vCenter avec une erreur de serveur interne

Summary: L’enregistrement de VMware vCenter peut échouer dans OMEVV 1.3 avec une chaîne de certificats personnalisée installée dans OpenManage Enterprise (OME) ou vCenter.

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Symptoms

OpenManage Enterprise Integration for VMware vCenter (OMEVV) 1.3 (OME 4.0.x) peut ne pas réussir à enregistrer vCenter avec l’erreur «internal server error« suivi de l’erreur »Client is temporarily blocked for too many unsuccessful authentication attempts«
Le problème est observé lors de l’utilisation d’une chaîne de certificats dans OpenManage Enterprise, qui dispose d’un certificat d’autorité de certification racine avec un algorithme de SHA1RSA.

Écran d’erreur interne du serveur
Lorsque l’enregistrement est de nouveau tenté, le message d’erreur suivant peut s’afficher.


Erreur d’écran « Le client est temporairement bloqué »

Le problème est également observé lorsque VMware vCenter dispose d’un certificat avec SHA1 dans la chaîne de certificats.
La commande suivante peut être utilisée pour obtenir les détails du certificat à partir de l’appliance OpenManage Enterprise (OME) ou de VMware vCenter.

openssl s_client -showcerts -connect vcenter_IP:443 > vCenter_certificate.txt
openssl s_client -showcerts -connect OME_IP:443 > OME_certificate


Assurez-vous qu’OpenSSL est installé sur le client sur lequel la commande est exécutée.

Cause

L’algorithme SHA1 est considéré comme faible et bloqué pour tous les certificats, y compris l’autorité de certification racine.

Resolution

Solution de contournement :
si l’algorithme SHA1 fait partie de l’autorité de certification racine ou d’un certificat signé d’une autorité de certification publique et qu’il est nécessaire pour effectuer la migration d’OME, procédez comme suit :
  • Pour migrer d’OpenManage Enterprise 3.10.x vers la version 4.0.x, une chaîne de certificats est requise.
  • Une fois la migration terminée, un certificat Leaf (certificat de fin OME) avec l’algorithme SHA2 peut être téléchargé vers OpenManage Enterprise sous la forme d’un certificat et non d’une chaîne.
  • Une fois le nouveau certificat leaf sans chaîne chargé, redémarrez l’appliance et tentez l’enregistrement de vCenter.

Solution :
il est recommandé de ne pas utiliser de certificats SHA1 dans OpenManage Enterprise. Essayez d’utiliser une chaîne de certificats sans l’algorithme SHA1 dans le certificat, puis essayez l’enregistrement. La prochaine version d’OMEVV bénéficiera d’une amélioration pour la prise en charge de SHA1 dans l’autorité de certification racine.

Affected Products

OpenManage Enterprise Integration for VMware vCenter, VMware ESXi 7.x, VMware ESXi 8.x

Products

C Series, Modular Infrastructure, Rack Servers, Tower Servers, XR Servers, Dell EMC OpenManage Enterprise
Article Properties
Article Number: 000223404
Article Type: Solution
Last Modified: 01 May 2025
Version:  2
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