OpenManage Enterprise: OMEVV, dahili sunucu hatasıyla vCenter'ı kaydetmekte başarısız olabilir

Summary: VMware vCenter kaydı, OpenManage Enterprise (OME) veya vCenter'da özel bir sertifika zinciri yüklüyken OMEVV 1.3'te başarısız olabilir.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

VMware vCenter (OMEVV) 1.3 (OME 4.0.x) için OpenManage Enterprise Integration, vCenter'ı bir hatayla kaydetmekte başarısız olabilirinternal server error" ve ardından hata "Client is temporarily blocked for too many unsuccessful authentication attempts"
Sorun, OpenManage Enterprise'da SHA1RSA algoritmasına sahip bir kök CA sertifikasına sahip bir Sertifika zinciri kullanılırken gözlemleniyor.

Dahili sunucu hata ekranı
Kayıt yeniden denendiğinde aşağıdaki hata görüntülenebilir.


İstemci geçici olarak engellendi ekranı hatası

Bu sorun, VMware vCenter'ın sertifika zincirinde SHA1'e sahip bir sertifikası olduğunda da görülür.
OpenManage Enterprise (OME) cihazından veya VMware vCenter'dan sertifika ayrıntılarını almak için aşağıdaki komut kullanılabilir.

openssl s_client -showcerts -connect vcenter_IP:443 > vCenter_certificate.txt
openssl s_client -showcerts -connect OME_IP:443 > OME_certificate


Komutun çalıştırıldığı istemcide OpenSSL'nin yüklü olduğundan emin olun.

Cause

SHA1 Algoritması zayıf olarak kabul edilir ve kök CA dahil tüm sertifikalar için engellenir.

Resolution

Geçici çözüm:
SHA1 Algoritması kök CA'nın veya genel CA'nın çapraz imzalı sertifikasının bir parçasıysa ve OME geçişini tamamlamak için gerekliyse aşağıdaki adımları uygulayın:
  • OpenManage Enterprise 3.10.x'den 4.0.x e geçiş yapmak için bir sertifika zinciri gerekir.
  • Geçiş tamamlandıktan sonra, SHA2 algoritmasına sahip bir Leaf sertifikası (OME son sertifikası), OpenManage Enterprise'a zincir olarak değil sertifika olarak yüklenebilir.
  • Zinciri olmayan yeni yaprak sertifika yüklendikten sonra cihazı yeniden başlatın ve vCenter kaydını deneyin.

Çözüm:
OpenManage Enterprise'da SHA1 sertifikalarının kullanılmaması önerilir. Sertifikada SHA1 algoritması olmayan bir sertifika zinciri kullanmayı deneyin, ardından kaydı deneyin. OMEVV'nin bir sonraki sürümü, kök CA'da SHA1'i desteklemek için bir iyileştirme içerecektir.

Affected Products

OpenManage Enterprise Integration for VMware vCenter, VMware ESXi 7.x, VMware ESXi 8.x

Products

C Series, Modular Infrastructure, Rack Servers, Tower Servers, XR Servers, Dell EMC OpenManage Enterprise
Article Properties
Article Number: 000223404
Article Type: Solution
Last Modified: 01 May 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.