OpenManage Enterprise: OMEVV може не зареєструвати vCenter через внутрішню помилку сервера

Summary: Реєстрація VMware vCenter може не вдатися в OMEVV 1.3 з користувацьким ланцюжком сертифікатів, встановленим в OpenManage Enterprise (OME) або vCenter.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

OpenManage Enterprise Integration for VMware vCenter (OMEVV) 1.3 (OME 4.0.x) може не змогти зареєструвати vCenter з помилкою «internal server error" з подальшою помилкою "Client is temporarily blocked for too many unsuccessful authentication attempts«
Проблема спостерігається під час використання ланцюжка сертифікатів у OpenManage Enterprise, який має кореневий сертифікат ЦС з алгоритмом SHA1RSA.

Екран внутрішньої помилки сервера
При повторній спробі реєстрації може з'явитися наступна помилка.


Помилка екрана тимчасово заблокованого клієнта

Проблема також спостерігається, коли VMware vCenter має сертифікат із SHA1 у ланцюжку сертифікатів.
Наведену нижче команду можна використовувати для отримання відомостей про сертифікат із пристрою OpenManage Enterprise (OME) або VMware vCenter.

openssl s_client -showcerts -connect vcenter_IP:443 > vCenter_certificate.txt
openssl s_client -showcerts -connect OME_IP:443 > OME_certificate


Переконайтеся, що OpenSSL встановлено на клієнті, де виконується команда.

Cause

Алгоритм SHA1 вважається слабким і блокується для всіх сертифікатів, включаючи кореневий ЦС.

Resolution

Спосіб вирішення:
Якщо алгоритм SHA1 є частиною кореневого ЦС або перехресно підписаного сертифіката публічного ЦС і потрібен для завершення міграції OME, виконайте наступні кроки:
  • Для міграції з OpenManage Enterprise 3.10.x на 4.0.x потрібен ланцюжок сертифікатів.
  • Після завершення міграції сертифікат Leaf (кінцевий сертифікат OME) з алгоритмом SHA2 може бути завантажений в OpenManage Enterprise як сертифікат, а не як ланцюжок.
  • Після завантаження нового листового сертифіката без ланцюга перезапустіть пристрій і спробуйте зареєструватися в vCenter.

Рішення:
Рекомендується, щоб сертифікати SHA1 не використовувалися в OpenManage Enterprise. Спробуйте використати ланцюжок сертифікатів без алгоритму SHA1 у сертифікаті, а потім спробуйте зареєструватися. Наступний реліз OMEVV матиме покращення для підтримки SHA1 у кореневому CA.

Affected Products

OpenManage Enterprise Integration for VMware vCenter, VMware ESXi 7.x, VMware ESXi 8.x

Products

C Series, Modular Infrastructure, Rack Servers, Tower Servers, XR Servers, Dell EMC OpenManage Enterprise
Article Properties
Article Number: 000223404
Article Type: Solution
Last Modified: 01 May 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.