Connectrix B 系列:无法将许可证密钥添加到交换机,并显示错误“无法提交许可证更改”
Summary:
无法使用“licenseadd”将许可证添加到 MX610s 交换机 “命令(适用于 FOS 版本 8.1.x)。命令“License install -k”和“License -install” “在 FOS 版本 8.1.x 上不受支持。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
错误:
Switch-A:admin licenseadd "W4ZfEaJftZaSJAJJQRff37KSKHRgJrFrEFPfQFH*****" adding license-key [W4ZfEaJftZaSJAJJQRff37KSKHRgJrFrEFPfQFH*****] failed to commit license changes
Cause
由于以下错误,无法运行 Supportsave 和许可证安装:
"The switch does not have enough disk space to run full supportsave. Available Free disk space is 0 MB."
Switch-A:admin> supportsave This command collects RASLOG, TRACE, supportShow, core file, FFDC data and then transfer them to a FTP/SCP/SFTP server or a USB device. This operation can take several minutes. OK to proceed? (yes, y, no, n): [no] yes Host IP or Host Name: 10.82.50.27 User Name: username Password: ****** Protocol (ftp | scp | sftp): sftp Remote Directory: /home/inti/brocade Do you want to continue with CRA (Y/N) [N]: The switch does not have enough disk space to run full supportsave. Available Free disk space is 0 MB. Please run the following commands to release disk space and retry full supportsave 1. "supportsave -k" to transfer core files to remote location 2. "supportsave -R" to remove the core files in the switch SupportSave failed.从以下命令中查找要删除的核心文件:
Switch-A:admin> supportsave -R No core or FFDC data files found! SupportSave completed.
Resolution
有几种可能的方法可以解决此问题:
- 修复 1:
- 运行以下命令以确认是否启用了 root 帐户。
userconfig --show root
- 使用 root 帐户,删除
/var/log/esmd_lib.log可能会占用更多闪存的文件
- 从 root 捕获以下命令的输出。
root> ls lR /var
在此输出中,应会看到以下内容:
/var/log: -rw-r--r-- 1 root root 3113586 Oct 14 11:16 esmd_lib.log -rw-r--r-- 1 root admin 14065977 Oct 13 05:17 esmd_lib.log.1 -rw-r--r-- 1 root admin 82593068 Oct 7 11:04 esmd_lib.log.2 -rw-r--r-- 1 root root 329366414 Sep 2 13:41 esmd_lib.log.3
- 从 root 用户发出以下命令以删除文件
rm /var/log/esmd_lib.log rm /var/log/esmd_lib.log.1 rm /var/log/esmd_lib.log.2
这将清理闪存并允许
supportsave 要运行。
- 收集
supportsave并使用以下命令安装许可证licenseadd <key>命令。 - 如果启用了 root 帐户,请运行以下命令,删除临时和不需要的固件文件。
df -k
如果未启用 root 帐户,您可能由于内存问题而无法启用。如果 root 帐户被禁用,请按照修复 2 进行操作。
Switch_A:admin> userconfig --show root Account name: root* Description: root Enabled: No Password Last Change Date: Unknown (UTC) Password Expiration Date: Not Applicable (UTC) Locked: No Role: root AD membership: 0-255 Home AD: 0 Day Time Access: N/A
Switch_A:admin> userconfig --change root -e yes sqlite3_exec error: 10 disk I/O error Failed to change user account attributes
- 修复 2:
- 备份配置并执行
Hareboot在维护窗口下清除闪存问题。 - 执行后
Hareboot收集supportsave日志,并尝试使用以下命令安装许可证:licenseadd <key>相同名称。
- 修复 3:
如果修复 2 无法清除闪存或启用 root 帐户,请在执行交换机更换之前联系交换机供应商以获得进一步的帮助。
Additional Information
Affected Products
Dell EMC Networking MX-G610sArticle Properties
Article Number: 000223916
Article Type: Solution
Last Modified: 10 May 2024
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.