Connectrix B-Series:無法新增授權金鑰至交換器,並出現錯誤「無法認可授權變更」

Summary: 無法使用「licenseadd」將授權新增至 MX610s 交換器 命令,以取得 FOS 版本 8.1.x 的驗證。命令「License install -k」和「License -install “在 FOS 版本 8.1.x 不受支援。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Error:
Switch-A:admin licenseadd "W4ZfEaJftZaSJAJJQRff37KSKHRgJrFrEFPfQFH*****"
adding license-key [W4ZfEaJftZaSJAJJQRff37KSKHRgJrFrEFPfQFH*****]
failed to commit license changes

Cause

無法執行 Supportsave 和授權安裝,因為發生錯誤:
 "The switch does not have enough disk space to run full supportsave. Available Free disk space is 0 MB."
 
Switch-A:admin> supportsave
This command collects RASLOG, TRACE, supportShow, core file, FFDC data
and then transfer them to a FTP/SCP/SFTP server or a USB device.
This operation can take several minutes.
OK to proceed? (yes, y, no, n): [no] yes
Host IP or Host Name: 10.82.50.27
User Name: username
Password: ******
Protocol (ftp | scp | sftp): sftp
Remote Directory: /home/inti/brocade
Do you want to continue with CRA (Y/N) [N]:
The switch does not have enough disk space to run full supportsave. Available Free disk space is 0 MB.
Please run the following commands to release disk space and retry full supportsave
1. "supportsave -k" to transfer core files to remote location
2. "supportsave -R" to remove the core files in the switch
SupportSave failed.
從以下命令中尋找要刪除的核心檔案:
Switch-A:admin> supportsave -R
No core or FFDC data files found!
SupportSave completed.

Resolution

有幾種可能的方法可解決此問題:
  • 修正 1:
  1. 執行以下命令以確認是否已啟用根帳戶。
 userconfig --show root
  1. 使用 root 帳戶,移除 /var/log/esmd_lib.log 可能需要更多快閃記憶體的檔案
  1. 從 root 擷取下列命令的輸出。
root> ls lR /var
在此輸出中,應看到以下內容:
/var/log:

-rw-r--r--   1 root     root      3113586 Oct 14 11:16 esmd_lib.log
-rw-r--r--   1 root     admin    14065977 Oct 13 05:17 esmd_lib.log.1
-rw-r--r--   1 root     admin    82593068 Oct  7 11:04 esmd_lib.log.2
-rw-r--r--   1 root     root     329366414 Sep  2 13:41 esmd_lib.log.3
  1. 從根發出下列命令以移除檔案
rm /var/log/esmd_lib.log
rm /var/log/esmd_lib.log.1
rm /var/log/esmd_lib.log.2
這會清理快閃記憶體,並允許 supportsave 待運行。
  1. 收集 supportsave 並使用以下方式安裝授權: licenseadd <key> 清理快閃記憶體後的命令。
  2. 如果已啟用根帳戶,請執行以下命令,以移除暫存和不需要的韌體檔案。
df -k 
 
如果未啟用 root 帳戶,您可能會因為記憶體問題而無法啟用。如果根帳戶已停用,請按照修正 2 操作。
Switch_A:admin> userconfig --show root
Account name: root*
Description: root
Enabled: No
Password Last Change Date: Unknown (UTC)
Password Expiration Date: Not Applicable (UTC)
Locked: No
Role: root
AD membership: 0-255
Home AD: 0
Day Time Access: N/A
Switch_A:admin> userconfig --change root -e yes
sqlite3_exec error: 10 disk I/O error
Failed to change user account attributes
  • 修正 2:
  1. 備份組態並執行 Hareboot 在維護空檔下清除快閃記憶體問題。
  2. 表演後 Hareboot、收集 supportsave 記錄並嘗試安裝授權,使用 licenseadd <key> 命令。
  • 修正 3:
如果修正 2 無法清除快閃記憶體或啟用 root 帳戶,請在執行交換器更換前,聯絡交換器廠商以取得進一步協助。

Additional Information

Affected Products

Dell EMC Networking MX-G610s
Article Properties
Article Number: 000223916
Article Type: Solution
Last Modified: 10 May 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.