Dell Unity: Eicar Malware Testing på Unity NAS får en nettverksfeil

Summary: Bruker testet med Eicar-testing av skadelig programvare i en Unity NAS-server, og som viser en nettverksfeil "Det er et problem med tilgang til \\172.xx.xx.xx\abc (NasIP \testfolder)." Denne feilen kan rettes opp av brukeren. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

EICAR Anti-Virus Test File eller EICAR test file er en datafil utviklet av European Institute for Computer Anti-Virus Research (EICAR) og Computer Anti-Virus Research Organization (CARO) for å teste responsen av computer anti-virus (AV) programmer.

Brukeren er en AV-tredjepartsmotor som er Sophos Central Intercept X.
There is a problem accessing \\172.xx.xx.xx\abc  (NasIP \testfolder ) 
You have received this message because an event that has occurred on your Unity system requires your attention. The alert is:
"The virus checker server 172.xx.xx.xx has encountered an error and is no longer operational.(Error: OFFLINE, httpStatus: 1006 Connection Disconnected)"
The virus checker server 172.xx.xx.xx has encountered an error and is no longer operational.(Error: ERROR_AVINTERFACE)"
"No virus checker server is available."
 
Eicar nettverksfeil

Cause

Denne feilen er en klar indikasjon på at Windows Server som kjører tredjeparts AV-programvare og Cava Agent, ikke var tilgjengelig for å tilby tjenester i løpet av varslingsperioden. Hvis Unity Appliance ellers er i god stand, kan problemet enten skyldes nettverksbrudd eller et Windows-Server-problem, eller muligens et AV-tjenesterelatert problem. Brukeren eller en Windows-administrator må undersøke Windows-varslingsloggen for en klar grunnårsak.

    Resolution

    Feilsøkingstrinn fra Unity:

    1. Søk i Unity-loggplassering:
    EMCSystemBackup.log  - cd /EMC/C4core/log/
    grep -i infect EMCSystemBackup.log
    grep -i blocked EMCSystemBackup.log
    
    c4_safe_ktrace.log – cd /EMC/C4core/log/
    grep -i "virus checker" c4_safe_ktrace.log
    zgrep -i "virus checker" /EMC/C4core/log/c4_safe_ktrace.log*

    Uemcli svc_cava tjenesteskript med NAS-servernavn inneholder CAVA-versjon og navn på antivirusmotor.
    Nas server name/IP : OV-xx-x-xxx-xx-001/ 172.xx.xx.xx
    AV server IP address: 172.xx.xx.xx
     
    AV-infiserte filer
     
    Liste over kommandoer:
    Command Usage: svc_cava
    svc_cava { <NAS_Server_Name> | ALL }
     [-h | --help]
     | <no option>
     | -stats
     | [ -set accesstime={ now | none | [[[[yy]mm]dd]hh]mm[.ss] }]
     | [ -fsscan [<fs_mountpath> { -list | -create | -delete } ]
    Example : svc_cava -stats
    svc_cava nas1 -stats
    svc_cava nas1

    Kommandobruk:
    08:38:39 root@DE4142343780xx spa:/EMC/C4Core/log# svc_cava OV-xxx-x-xxx-xx-001 -stats
    OV-xxx-x-xxx-xx-001 : commands processed: 1
    command(s) succeeded
    output is complete 
    1712653384: VC: 5: Total Requests: 0.
    1712653384: VC: 5:
    1712653384: VC: 5: NO ANSWER from the Virus Checker Servers: 0.
    1712653384: VC: 5: ERROR_SETUP: 0.
    1712653384: VC: 5: FAIL: 0.
    1712653384: VC: 5: TIMEOUT: 0.
    1712653384: VC: 5:
    1712653384: VC: 5: 0 files in the collector queue.
    1712653384: VC: 5: 0 files processed by the AV threads.
    Command succeeded
    1. Last ned filen viruschecker.config og kontroller om shutdown=no eller shutdown=viruschecking vises:

    Åpne Unity UI>Storage > NAS server >Security >Anti-virus >Hent gjeldende konfigurasjon (vis filen) 

    1. Oppdater viruschecker.conf-verdien (Last opp ny konfigurasjon) og bruk endringene:
    # Example: OV-xxx-x-xxx-xx-001
    #
    masks=*.EXE:*.COM:*.DOC:*.DOT:*.XL?:*.MD?:*.VXD:*.386:*.SYS:*.BIN:*.ppt:*docx:*.rar:*.zip:*.txt
    excl=pagefile.sys:*.tmp
    # masks=*.RTF:*.OBD:*.DLL:*.SCR:*.OBT:*.PP?:*.POT:*.OLE:*.SHS:*.MPP
    # masks=*.MPT:*.XTP:*.XLB:*.CMD:*.OVL:*.DEV
    # masks=*.ZIP:*.TAR:*.ARJ:*.ARC:*.Z
    addr=172.xx.xx.xx >> AV Server IP address
    shutdown=no (update the value to shutdown=viruschecking and upload the viruschecker.conf file to unity GUI)
    # Stops SMB/CIFS if no AV machine available.(No Windows clients can access any Unity share)
    

     

    08:18:51 root@DE414234378xxx spa:/cores/service/user# svc_cava OV-xxx-x-xxx-xx-001
    OV-xxx-x-xxx-xx-001: commands processed: 1
    command(s) succeeded
    output is complete
    1712650760: VC: 5: OV-xxx-x-xxx-xx-001: Enabled and Started.
    1712650760: VC: 5: 1 Checker IP Address(es):
    1712650760: VC: 5: 172.xx.xx.xx                                   ONLINE at Tue Apr  9 08:19:14 2024 (GMT-00:00)
    1712650760: VC: 5:                                                HTTP, CAVA version: 8.9.10.0
    1712650760: VC: 5:                                                AV Engine: Microsoft Antivirus ( Third party AV Engine )
    1712650760: VC: 5:                                                Remediation Window: 30 seconds
    1712650760: VC: 5:                                                Server Name: 172.xx.xx.xx
    1712650760: VC: 5:                                                Last time signature updated: Tue Apr  9 05:29:36 2024 (GMT-00:00)
    1712650760: VC: 5:
    1712650760: VC: 5: 15 File Mask(s):
    1712650760: VC: 5: *.EXE *.COM *.DOC *.DOT *.XL? *.MD? *.VXD *.386 *.SYS *.BIN *.PPT *DOCX *.RAR
    1712650760: VC: 5: *.ZIP *.TXT
    1712650760: VC: 5: 2 Excluded File(s):
    1712650760: VC: 5: PAGEFILE.SYS *.TMP
    1712650760: VC: 5: Share \\ov-yml-p-ser-fs-001.yoma.com.mm\CHECK$.
    1712650760: VC: 5: RPC request timeout=25000 milliseconds.
    1712650760: VC: 5: RPC retry timeout=5000 milliseconds.
    1712650760: VC: 5: High water mark=200.
    1712650760: VC: 5: Low water mark=50.
    1712650760: VC: 5: Scan all virus checkers every 10 seconds.
    1712650760: VC: 5: When all virus checkers are offline:
    1712650760: VC: 5: Continue to work with Virus Checking and CIFS.
    1712650760: VC: 5: Scan on read disable.
    1712650760: VC: 5: MS-RPC User: OV-xxx-x-xxx-xx-001-FS$
    1712650760: VC: 5: MS-RPC ClientName: ov-xxx-x-xxx-xx-001.abc
     Command succeeded
    
    

    Problemet ble løst, og CAVA begynte å fungere ordentlig etter endring av nettverks-IP.

    Feilsøking av anbefaling:
    1. Bekreft viruschecker.conf innstillinger. (shutdown = viruschecking)
    2. Bekreft at CAVA-tjenesten kjører med AV-brukerkontoen.
    3. Bekreft at den installerte antivirustjenesten (Sophos, TrendMicro, McAfee og så videre) kjører med den lokale systemkontoen.
    4. Bekreft at AV-brukeren er medlem av den lokale administratorgruppen på hver AV-server.
    5. Bekreft at anti-virus og CEE er installert i riktig rekkefølge, CEE først, deretter anti-virus
    6. Start CAVA-tjenestene på nytt
    7. Start AV-serveren på nytt én gang
    8. Bekreft at CAVA-serverne bare har ett nettverksgrensesnitt.
    9. Bekreft med brukeren om klientdatamaskinen er tilordnet samme eller forskjellige nettverks-IPer for NAS-servere (anbefales alltid at den er i samme nettverk)
    I dette scenariet er tredjeparts AV-motoren Sophos Central Intercept X, men det reflekteres som Microsoft Anti-virus. Dette er grunnen til at Microsoft-leverandøren må være deaktivert (trinnene og artikkelen er nevnt for å deaktivere Microsoft Anti-virus)
    1712650760: VC: 5:                                                HTTP, CAVA version: 8.9.10.0
    1712650760: VC: 5:                                                AV Engine: Microsoft Antivirus ( Third party AV Engine )

    Beste framgangsmåte:
    1. Ikke sett opp Policy VirusChecking=Nei, da dette kan føre til blokkerte tråder og ikke anses som beste praksis.
    2. Ikke bruk en enkel AV-server, da dette ikke anbefales.
    3. Ikke bruk en enkelt AV-server for flere plattformer, da dette ikke anbefales og bør betraktes som ikke støttet.

    Hvis problemet vedvarer, må brukeren engasjere tredjeparts antivirusleverandørstøtte for ytterligere hjelp.

    Additional Information

    Affected Products

    Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family
    Article Properties
    Article Number: 000224432
    Article Type: Solution
    Last Modified: 16 Oct 2025
    Version:  3
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.