NVE: /root sahipliği değiştirildiğinde İşletim Sistemi Toplaması "Bir veya Daha Fazla Düğüm SLES Çalıştırmaz" İşleminde Başarısız Oluyor

Summary: NetWorker Virtual Edition (NVE) işletim sistemi paketi "Bir veya Daha Fazla Düğüm SLES Çalıştırmıyor" raporuyla başarısız oluyor. /root'un sahipliği başka bir kullanıcı olarak değiştirildi. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker Virtual Edition paketi başarısız olur ve şurada hata bildirilir: /usr/local/avamar/var/avi/server_data/package_data/NvePlatformOsRollup_YYYY-R#-v#.avp_EPOCH_TIMESTAMP/workflow.log

YYYY-MM-DD HH:mm:SS (-TZ) 4107124 INFO: no output seen from "ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no  root@127.0.0.1  uname -a"
YYYY-MM-DD HH:mm:SS (-TZ) 4107124 INFO: post: "ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no  root@127.0.0.1  uname -a", exit status=255 (error)
YYYY-MM-DD HH:mm:SS (-TZ) 4107124 INFO: address=127.0.0.1 remote=ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no  root@127.0.0.1  os=unknown version=unknown update=unknown arch=unknown
YYYY-MM-DD HH:mm:SS (-TZ) 47378741877400 INFO:  - One or more nodes are not running SLES succeeded

OsRollup iş akışı günlükleri rollups package_data dizininde bulunabilir:

/usr/local/avamar/var/avi/server_data/package_data/NvePlatformOsRollup_YYYY-R#-v#.avp_EPOCH_TIMESTAMP/workflow.log

Cause

Mülkiyeti /root Dizin, bir noktada yedekleme yöneticisi tarafından değiştirildi. Örneğin, şunları gösterir:

nve:~ # ls -ld /root
drwx------   8 admin  root    4096 May 16 09:27 root

İzinleri /root başka hiçbir kullanıcı veya grubun dizine erişimi olmayacak, yalnızca sahip (bu durumda yönetici) erişebilecek şekildedir.

Toplama sırasında aşağıdaki komut çalıştırılır:

ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no root@127.0.0.1 uname -a

Koşmaya çalışır as_root, ancak yalnızca yönetici kullanıcının erişimi olduğundan komut hiçbir şey döndürmez ve çekirdek güncelleştirmesini atlar. Örneğin:

nve:~ # ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no root@127.0.0.1 uname -a
nve:~ # 

Ne zaman /root sahibidir root:root gibi bir şey döndürmesi gerektiğini:

nve:~ # ssh -q -i /root/.ssh/rootid -x -q -o ConnectTimeout=5 -o PasswordAuthentication=no -o StrictHostKeyChecking=no -o GSSAPIAuthentication=no root@127.0.0.1 uname -a
Linux nve 4.12.14-122.153-default #1 SMP Tue Mar 7 14:13:19 UTC 2023 (9f7af45) x86_64 x86_64 x86_64 GNU/Linux
nve:~ #

Eğer /root başka bir kullanıcıya aitse, ssh almak için komut uname -a hiçbir şey döndürmüyor, bu da iş akışının işletim sistemini "bilinmiyor" olarak bildirmesine ve NVE'nin işletim sistemi paketi güncelleştirmelerini atlamasına neden oluyor.

NOT: Bu KB de özetlenen arızanın tek nedeni bu değildir. Daha fazla bilgi için bkz. Bu makalenin odak noktası, burada özetlenen belirli nedene yönelik çözümdür.

Resolution

Düzeltin /root sahiplik:

sudo chown root:root /root

NVE kurulum yöneticisine dönün ve geçerli görevi yeniden deneyin.

NOT: "Kök" kullanıcı ve grup, /root dizini. NVE'deki varsayılan sistem dosyalarını ve ayarlarını değiştirmek, toplamalar/yükseltmeler sırasında sorunlara neden olabilir, NVE'yi bozabilir ve yeniden dağıtım ve NetWorker Sunucusu Olağanüstü Durum Kurtarma (nsrdr). Bu nedenle, varsayılan sistem dosyalarını veya ayarlarını değiştirmeniz önerilmez.

Köke SSH erişimine izin vermek için bkz.: NVE: NetWorker Virtual Edition da Kök SSH Erişimine İzin Verme

Additional Information

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000225150
Article Type: Solution
Last Modified: 04 Dec 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.