Uzel Metro: SSH bez hesla k uzlu nebo direktoru selže.

Summary: Tento článek hovoří o problému, při kterém budete vyzváni k zadání hesla při pokusu o přístup k uzlu / nástroji director metro. Nejedná se o očekávané chování, protože uzel Metro podporuje při použití účtu služby protokol SSH mezi uzly nebo řediteli bez hesla. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Dotčený hardware uzlu metro:
Hardware Dell: Uzel Metro – mn114/mn215
Hardware Dell: Uzel Metro – místní nebo Metro

Poznámka: Uzel metro mn215 podporuje pouze uzel metro OS 8.0.0 a novější.

 

Dotčené verze operačního systému uzlu Metro:
Software Dell: Uzel Metro OS 7.x
Software Dell: OS uzlu Metro 8.x

 

Problémy:
Při pokusu o připojení přes SSH k libovolnému uzlu Metro nebo směrovačům s účtem služby budete vyzváni k zadání hesla následujícím způsobem:

Příklad: (Níže uvedený výstup znázorňuje, že uzel B nemůže provádět připojení SSH k uzlu A bez hesla)

service@director-1-1-b:~> ssh 128.221.252.35
Password:

 

Příznaky:
Všichni ředitelé podávají zprávy director-x-y-z : Systemd IO error: Cannot determine the state of system na výstupu "Cluster Status" takto:

Příklad:

VPlexcli:/> cluster status
WARNING: There are unreachable directors: director-1-1-A. Connectivity may still have errors even if none are reported.

Cluster cluster-1
        operational-status:            degraded
        transitioning-indications:     disk(s) not visible from all directors,meta data problem
        transitioning-progress:
        health-state:                  degraded
        health-indications:            director-1-1-A : Systemd IO error:  Cannot determine the state of system services

        local-com:                     connectivity: NONE

LC-00 ports - FAIL - Failed to determine expected connectivity.
LC-01 ports - FAIL - Failed to determine expected connectivity.

Cluster Name Port Group MTU  Connectivity Status
------------ ---------- ---- ------------ -----------
cluster-1    LC-00      1500 fail         all-enabled
             LC-01      1500 fail         all-enabled
cluster-2    LC-00      1500 fail         all-enabled
             LC-01      1500 fail         all-enabled

     man-com:                       connectivity: NONE

MC-01 ports - FAIL - Failed to determine expected connectivity.
MC-00 ports - FAIL - Failed to determine expected connectivity.

Cluster Name Port Group MTU  Connectivity Status
------------ ---------- ---- ------------ -----------
cluster-1    MC-00      1500 fail         all-enabled
             MC-01      1500 fail         all-enabled
cluster-2    MC-00      1500 fail         all-enabled
             MC-01      1500 fail         all-enabled

Cluster cluster-2
        operational-status:            ok
        transitioning-indications:
        transitioning-progress:
        health-state:                  ok
        health-indications:
        local-com:                     ok
        man-com:                       ok

wan-com: ok

 

Cause

K tomuto problému může dojít, pokud jsou oprávnění adresáře služby změněna na úplný přístup (777) (oprávnění ke čtení, zápisu a spuštění)

 

Resolution

Kroky alternativního řešení:

  1. Přihlaste se k dotčenému uzlu jako servisní uživatel a přejděte do části service-maintenance-window zadáním níže uvedeného příkazu z příkazového řádku service/Linux:

    sudo /usr/sbin/service-maintenance-window -f
  2. Zkontrolujte a změňte oprávnění definovaná pro adresář služby v dotčeném uzlu následujícím způsobem:

    Příklad: (Dotčený uzel A uzlu metro, viz část příznaku)

    From:
    director-1-1-a:/home # ll
    total 28
    drwxr-x---  6 admin      users  4096 Aug 20  2021 admin
    drwxr-x---  6 eseservice users  4096 Aug 20  2021 eseservice
    drwx------  2 root       root  16384 Mar  3  2022 lost+found
    drwxrwxrwx 11 service    users  4096 May 20 05:08 service
    
    To:
    director-1-1-a:/home # chmod 750 service
    director-1-1-a:/home # ll
    total 28
    drwxr-x---  6 admin      users  4096 Aug 20  2021 admin
    drwxr-x---  6 eseservice users  4096 Aug 20  2021 eseservice
    drwx------  2 root       root  16384 Mar  3  2022 lost+found
    drwxr-x--- 11 service    users  4096 May 20 05:08 service
  3. Pokuste se pomocí SSH zpět do dotčeného uzlu jako servisní uživatel a následujícím způsobem ověřte, zda můžete používat SSH bez hesla:

    Příklad: (Níže uvedený výstup ukazuje, že uzel B může úspěšně provádět SSH k uzlu A bez hesla)

    service@director-1-1-b:~> ssh 128.221.252.35
    Last login: Mon May 20 05:32:04 2024 from 10.107.104.132
    service@director-1-1-a:~>
  4. Spusťte znovu příkaz cluster status a ověřte, že se nezobrazily žádné chyby:

    VPlexcli:/> cluster status
    Cluster cluster-1
            operational-status:            ok
            transitioning-indications:
            transitioning-progress:
            health-state:                  ok
            health-indications:
            local-com:                     ok
            man-com:                       ok
    
    
    Cluster cluster-2
            operational-status:            ok
            transitioning-indications:
            transitioning-progress:
            health-state:                  ok
            health-indications:
            local-com:                     ok
            man-com:                       ok
    
    
    wan-com: ok

 

Additional Information

*Použití chmod v absolutním režimu*
V absolutním režimu jsou oprávnění reprezentována v číselné podobě (přesněji osmičková soustava). V tomto systému je každé oprávnění k souboru reprezentováno číslem.

 

r (čtení) = 4
W (zápis) = 2
x (provést) = 1
– (bez oprávnění) = 0
S těmito číselnými hodnotami je můžete kombinovat, a tak lze použít jedno číslo k reprezentaci celé sady oprávnění.

 

Číslo Permission
0
1 –X
2 -W-
3 (tj. 2+1) -Wx
4 R–
5 (tj. 4+1) R-X
6 (tj. 4+2) Rw-
7 (tj. 4+2+1) Rwx

 

Affected Products

metro node, metro node mn-114, metro node mn-215
Article Properties
Article Number: 000225209
Article Type: Solution
Last Modified: 21 May 2024
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.