VxRail: vSphere HA-Agent kann nicht installiert werden oder schlägt mit der folgenden Fehlermeldung fehl: Abgelehntes Kennwort für Nutzer "vpxuser"

Summary: VxRail: vSphere HA Agent kann nicht installiert oder konfiguriert werden.

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Symptoms

Der Node ist in vCenter nicht verfügbar.
Fehler in vCenter für ESXi:
Cannot complete login due to an incorrect username or password
vSphere HA agent cannot be installed or configured
Der Kunde hatte vCenter aufgrund eines Problems beim Upgraden einiger Nodes im Cluster zurückgesetzt. Die Nodes und VMs werden nicht mehr von vCenter verwaltet.
VXR014030 ALARM Check vSphere HA host status
Vsphere HA host status
Cannot synchronize host …………….

  Abbildung des Fehlers VXR014030 ALARM Überprüfen des vSphere HA-Hoststatus
hostd.log
Rejected password for user vpxuser from XXX.XX.XX.XX (ip address) 
Bild des Fehlers mit abgelehntem Kennwort für den Nutzer vpxuser von XXX.XX.XX.XX (IP-Adresse)
Die VMs auf dem Node werden weiterhin ausgeführt. Die vSAN-Integrität von CLI hat alle Tests grün gemeldet.
 esxcli vsan health cluster list
 
 
 

Cause

Dieses Problem tritt auf, wenn das zwischengespeicherte Kennwort für vpxuser auf dem Host falsch ist oder Ihr Konto in vCenter Server abgelaufen ist.
Dieser Hyperlink führt Sie zu einer Website außerhalb von Dell Technologies.
https://knowledge.broadcom.com/external/article?legacyId=2097171Der vpxuser ist ein Nutzer, der vom vCenter in ESXi generiert wird, sobald der Node hinzugefügt und wieder mit vCenter verbunden ist.

Resolution

Um dieses Problem zu beheben, trennen Sie die Verbindung zum Host und stellen Sie eine Verbindung her, anstatt den Schritt "Aus dem Bestand entfernen" zu verwenden, der oben in der VMware-Wissensdatenbank erwähnt wird.

Hinweis: Im KB2097171 umfasst dies das Entfernen des Node aus dem Bestand. Das Entfernen des Node aus dem vCenter-Bestand ist im Vergleich zur Option zum Trennen und erneuten Verbinden eine invasivere Aufgabe.
In einigen Situationen werden möglicherweise noch VMs auf dem Node ausgeführt. Diese VMs können aufgrund des Status "nicht verwalteter ESXi" möglicherweise nicht migriert oder auf einem anderen Node registriert werden.
Wenn ein Host aus dem Bestand entfernt wird, wird er vollständig aus dem vCenter-Management und der vSAN-Teilnahme entfernt. Vor dem Entfernen müssen alle VMs ausgeschaltet werden. Sobald der Node vCenter verlassen hat, müssen die VMs auf einem neuen Node registriert werden, um sie einzuschalten. Zum Vergleich: Wenn ein Host vom vCenter getrennt wird, nimmt er weiterhin am vSAN teil. Alle VMs, die sich auf dem Node befinden, werden ohne Probleme ausgeführt, selbst wenn der Host getrennt ist. 

Hinweis: Wenn Sie die Verbindung zu einem verwalteten Host trennen, werden vorübergehend alle Überwachungsaktivitäten ausgesetzt, die vCenter Server durchführt. Der verwaltete Host und die zugehörigen virtuellen Maschinen verbleiben im vCenter Server-Bestand. Dieser Hyperlink führt Sie zu einer Website außerhalb von Dell Technologies. https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vsphere.vcenterhost.doc/GUID-DE06875C-CB8C-442E-AC1D-24BFFA3F6705.htmlWenn der Node aufgrund eines zusätzlichen Serviceproblems nicht erneut verbunden werden kann, müssen alle VMs ausgeschaltet und neu gestartet werden, um zu versuchen, die Verbindung wiederherzustellen. 


Schritte: 
  • Trennen Sie den Node von vCenter https://docs.vmware.com/en/VMware-vSphere/7.0/com.vmware.vsphere.vcenterhost.doc/GUID-DE06875C-CB8C-442E-AC1D-24BFFA3F6705.htmlDieser Hyperlink führt Sie zu einer Website außerhalb von Dell Technologies.
  • Öffnen Sie eine SSH-Sitzung mit dem betroffenen Node:
  • Beenden Sie den folgenden Service: (Dieser Dienst muss beendet werden, bevor die Neuverbindung gestartet wird.) 
    /etc/init.d/vpxa stop
  • Entfernen Sie das Konto:
    esxcli system account remove -i vpxuser
  • Vergewissern Sie sich, dass das Konto nicht vorhanden ist: 
    esxcli system account list
  • Gehen Sie zurück zur vCenter-Benutzeroberfläche und verbinden Sie den Host (es werden einige Fehler im Hintergrund angezeigt, die auf Nutzer- und Kennwortfehler hinweisen. Fahren Sie einfach mit dem Assistenten fort).
  • Schließen Sie den Assistenten ab und der Node sollte wieder über vCenter verwaltet werden können.
 

Affected Products

VMware ESXi 6.7.X, VMware ESXi 7.x, VMware vCenter Server
Article Properties
Article Number: 000225410
Article Type: Solution
Last Modified: 28 May 2024
Version:  1
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