PowerFlex 4.X : Échec de la connexion à l’interface utilisateur PFMP

Summary: Échec de connexion à l’interface utilisateur de la plate-forme PowerFlex Manager : « Échec de l’initialisation », « L’utilisateur ne dispose pas des autorisations nécessaires pour afficher cette page » ...

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Symptoms

Message d’erreur :

Failure to initialize
User has no permissions to view this page

 

C’est ce que montrent les journaux Keycloak.

2024-04-15 16:49:00,976 ERROR [org.jgroups.protocols.JDBC_PING] (jgroups-915,keycloak-0-18534) JGRP000115: Could not open connection to database: org.postgresql.util.PSQLException: Connection to postgres-ha-pgbouncer.powerflex.svc.cluster.local:5432 refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections. 

Affichages des pods SSO

2024-04-16T06:33:32.230Z ERROR 1 --- [io-8083-exec-33] com.dell.sso.clients.KeycloakClient      : update token request failed 400 Bad Request: "{"error":"invalid_grant","error_description":"Session not active"}"

org.springframework.web.client.HttpClientErrorException$BadRequest: 400 Bad Request: "{"error":"invalid_grant","error_description":"Session not active"}"
        at org.springframework.web.client.HttpClientErrorException.create(HttpClientErrorException.java:103) ~[spring-web-6.1.5.jar:6.1.5] 
2024-04-16T06:33:32.230Z ERROR 1 --- [io-8083-exec-33] com.dell.sso.clients.KeycloakClient : update token request failed 400 Bad Request: "{"error":"invalid_grant","error_description":"Session not active"}" org.springframework.web.client.HttpClientErrorException$BadRequest: 400 Bad Request: "{"error":"invalid_grant","error_description":"Session not active"}"
2024-04-16T12:00:07.330Z ERROR 1 --- [io-8083-exec-31] com.dell.sso.clients.KeycloakClient      : update token request failed 400 Bad Request: "{"error":"invalid_grant","error_description":"Token is not active"}" 

 

Cause

Le problème Keycloak échoue avec « trop de redirections » affichées dans les journaux. Ce problème a été signalé dans plusieurs forums keycloak lors de l’utilisation de keycloak derrière un proxy inverse (Ingress) et aucun correctif viable n’est connu.

 

Resolution

Redémarrez les pods Keycloak dans k8. Attendez que la commande status revienne dans l’interpréteur de commandes, puis l’utilisateur peut se connecter avec succès à l’interface utilisateur.

kubectl rollout restart sts -n powerflex keycloak
kubectl rollout status sts -n powerflex keycloak

 

Affected Products

PowerFlex rack, VxFlex Ready Nodes, PowerFlex custom node, PowerFlex appliance R650, PowerFlex appliance R6525, PowerFlex appliance R660, PowerFlex appliance R6625, Powerflex appliance R750, PowerFlex appliance R760, PowerFlex appliance R7625 , PowerFlex appliance R640, PowerFlex appliance R740XD, PowerFlex appliance R7525, PowerFlex appliance R840 ...
Article Properties
Article Number: 000225511
Article Type: Solution
Last Modified: 13 Nov 2025
Version:  4
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