Unisphere for PowerMax non accessibile a causa di un problema dell'API REST Troppi file aperti
Summary: Unisphere for PowerMax non è accessibile.
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Symptoms
- Le chiamate API REST sono state controllate come indicato nella Guida all'installazione di Unisphere for PowerMax . Tutti i criteri sono stati soddisfatti.
- La nuova immagine dei container non ha risolto il problema.
- Il riavvio dei contenitori di gestione risolve il problema per alcuni giorni.
- Tutti i servizi erano attivi e funzionanti.
- Errori in run.log:
ERROR [em.spa.SPA] (EJB default - 13) com.emc.em.spa.datamanager.datalistener.RTCListener.Exception in opening DCF listen port (8089) in JVM (0):Too many open files
- Errori in symapi.log:
04/03/2024 00:21:34.858 19033 27 EMC:UNIVMAX emcSymDBLoad pdsDbOpen() failed [/var/symapi/db/symapi_db.bin] ([PDS/File] Error opening file [Errno: 24 - Too many open files])
Cause
È stato rilevato che lo script esterno utilizzato per eseguire e controllare le chiamate RESTAPI non chiudeva la connessione HTTPS dopo ogni chiamata RESTAPI.
Here 10.x.y.z is the REST API client, but it does not appear to be closing the HTTPS connection to Unisphere DMF IP 172.18.64.7: java 19033 19951 root 3835u IPv6 6326647 0t0 TCP 172.18.64.7:pcsync-https->10.x.y.z:52042 (ESTABLISHED)
Resolution
È stato rilevato che lo script esterno utilizzato per eseguire e controllare le chiamate RESTAPI non chiudeva la connessione HTTPS dopo ogni chiamata RESTAPI.
Lo script esterno è stato regolato per chiudere la connessione HTTPS dopo ogni chiamata RESTAPI e il problema è stato risolto.
Lo script esterno è stato regolato per chiudere la connessione HTTPS dopo ogni chiamata RESTAPI e il problema è stato risolto.
Additional Information
Per "Too many open files," cercare in LSOF.txt (LiSt of Open Files):
Questo file si trova in EMC Grabs nella cartella Host.
L'IP del client API REST è disponibile in:
Unisphere ->Azioni di supporto > ->Risorse server gestite
Affected Products
Unisphere for PowerMaxArticle Properties
Article Number: 000225588
Article Type: Solution
Last Modified: 20 Jan 2025
Version: 4
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