Data Protection Central: RabbitMQ nie uruchamia się

Summary: Ten artykuł zawiera procedurę dla Data Protection Central (DPC), gdy nie można uruchomić oprogramowania RabbitMQ po aktualizacji oprogramowania.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Jeśli uruchomienie oprogramowania RabbitMQ nie powiedzie się po aktualizacji oprogramowania DPC, stan pokazuje usługę RabbitMQ (rabbitmq-server) jest aktywowana, ale nigdy nie kończy się:
# /usr/local/dpc/bin/dpc status
Version: 19.9.0-13
msm-ui-main: active
msm-monitor: inactive
msm-elg: active
mongod: active
rabbitmq-server: activating
nginx: active
dp-iam: active
FIPS: disabled
#
Dziennik oprogramowania RabbitMQ zawiera błędy podczas uzyskiwania dostępu do magazynu komunikatów podczas uruchamiania. Na przykład w /var/log/dpc/rabbitmq/rabbit@<DPC Hostname>.log, pokazuje, że oprogramowanie RabbitMQ nie powiodło się podczas próby odbudowania indeksu:
2024-05-07 23:56:25.408992-04:00 [info] <0.230.0> Running boot step recovery defined by app rabbit
2024-05-07 23:56:25.410137-04:00 [info] <0.423.0> Making sure data directory '/var/lib/dpc/rabbitmq/mnesia/rabbit@<DPC Hostname>/msg_stores/vhosts/628WB79CIFDYO9LJI6DKMI09L' for vhost '/' exists
2024-05-07 23:56:25.412199-04:00 [info] <0.423.0> Starting message stores for vhost '/'
2024-05-07 23:56:25.412425-04:00 [info] <0.428.0> Message store "628WB79CIFDYO9LJI6DKMI09L/msg_store_transient": using rabbit_msg_store_ets_index to provide index
2024-05-07 23:56:25.413720-04:00 [info] <0.423.0> Started message store of type transient for vhost '/'
2024-05-07 23:56:25.413970-04:00 [info] <0.432.0> Message store "628WB79CIFDYO9LJI6DKMI09L/msg_store_persistent": using rabbit_msg_store_ets_index to provide index
2024-05-07 23:56:25.414552-04:00 [warning] <0.432.0> Message store "628WB79CIFDYO9LJI6DKMI09L/msg_store_persistent": rebuilding indices from scratch
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0> ** Generic server <0.369.0> terminating
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0> ** Last message in was {'$gen_cast',
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0>                            {submit_async,
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0>                                #Fun<rabbit_classic_queue_index_v2.11.72031207>,
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0>                                <0.367.0>}}
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0> ** When Server state == undefined
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0> ** Reason for termination ==
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0> ** {function_clause,
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0>        [{rabbit_queue_index,journal_minus_segment1,
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0>             [{no_pub,no_del,ack},
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0>              {{true,
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0>                   <<136,59,154,30,244,191,111,192,154,235,124,189,92,104,1,207,

Cause

Nie można uruchomić oprogramowania RabbitMQ z powodu dużej liczby zablokowanych komunikatów w kolejce.

W tym przykładzie w kolejce znajduje się ponad 800 MB danych:
<DPC Hostname>:/var/lib/dpc/rabbitmq/mnesia # du -h .
20K     ./rabbit@<DPC Hostname>/quorum/rabbit@<DPC Hostname>
20K     ./rabbit@<DPC Hostname>/quorum
58M     ./rabbit@<DPC Hostname>/msg_stores/vhosts/628WB79CIFDYO9LJI6DKMI09L/msg_store_persistent
824M    ./rabbit@<DPC Hostname>/msg_stores/vhosts/628WB79CIFDYO9LJI6DKMI09L/queues/BV3H25N6AGWF7TDIN2L5RE0DA
824M    ./rabbit@<DPC Hostname>/msg_stores/vhosts/628WB79CIFDYO9LJI6DKMI09L/queues
0       ./rabbit@<DPC Hostname>/msg_stores/vhosts/628WB79CIFDYO9LJI6DKMI09L/msg_store_transient
881M    ./rabbit@<DPC Hostname>/msg_stores/vhosts/628WB79CIFDYO9LJI6DKMI09L
881M    ./rabbit@<DPC Hostname>/msg_stores/vhosts
881M    ./rabbit@<DPC Hostname>/msg_stores
20K     ./rabbit@<DPC Hostname>/coordination/rabbit@<DPC Hostname>
20K     ./rabbit@<DPC Hostname>/coordination
881M    ./rabbit@<DPC Hostname>
0       ./rabbit@<DPC Hostname>-plugins-expand
881M    .
<DPC Hostname>:/var/lib/dpc/rabbitmq/mnesia #

Resolution

Aby rozwiązać ten problem, skorzystaj z poniższej procedury w celu odbudowania zasobów RabbitMQ:
  1. Wykonaj migawkę maszyny wirtualnej DPC lub wykonaj pełną kopię zapasową serwera DPC.
  2. SSH do DPC i zaloguj się jako "admin", a następnie zmień użytkownika na root:
su -
  1. Zatrzymaj usługę RabbitMQ (rabbitmq-server) za pomocą następującego polecenia:
service rabbitmq-server stop
  1. Zmień katalog na /var/lib/dpc/rabbitmq/mnesia:
cd  /var/lib/dpc/rabbitmq/mnesia
  1. Jeśli jest wystarczająca ilość wolnego miejsca w /tmp, skopiuj dane do folderu /tmp (Opcjonalnie):
cp -rp * /tmp
  1. Usuń dane w obszarze /var/lib/dpc/rabbitmq/mnesia przy użyciu następującego polecenia:
rm -rf *
  1. Uruchom ponownie usługę RabbitMQ, pliki w obszarze /var/lib/dpc/rabbitmq/mnesia należy zregenerować:
service rabbitmq-server start
  1. Uruchom ponownie usługi DPC:
/usr/local/dpc/bin/dpc restart

Przykładowe dane wyjściowe ze środowiska laboratoryjnego:
przykład przedstawiający regenerację struktury danych przez oprogramowanie RabbitMQ
Rysunek 1. Przykład przedstawiający narzędzie RabbitMQ ponownie generujące strukturę danych w obszarze /var/lib/dpc/rabbitmq/mnesia podczas rozruchu
  1. Zaloguj się do interfejsu użytkownika DPC , aby sprawdzić, czy DPC działa zgodnie z oczekiwaniami.
  2. Usuń podfoldery, które zostały wcześniej przeniesione do /tmp jeśli dane zostały skopiowane w kroku 5. 
  3. Gdy usługa powróci do normy, usuń migawkę maszyny wirtualnej DPC , jeśli została wykonana. 
 

Affected Products

Data Protection Central, PowerProtect DP4400, PowerProtect DP5300, PowerProtect DP5800, PowerProtect DP8300, PowerProtect DP8800, PowerProtect Data Protection Software, Integrated Data Protection Appliance Family , Integrated Data Protection Appliance Software, PowerProtect DP5900, PowerProtect DP8400, PowerProtect DP8900 ...
Article Properties
Article Number: 000225640
Article Type: Solution
Last Modified: 27 Jun 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.