Data Protection Central: Software RabbitMQ se nedaří spustit.
Summary: Tento článek obsahuje postup pro Data Protection Central (DPC), když se po aktualizaci softwaru nepodaří spustit software RabbitMQ.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Pokud se po aktualizaci softwaru DPC nepodaří spustit software RabbitMQ, zobrazí se stav služby RabbitMQ (
rabbitmq-server) se aktivuje, ale nikdy nedokončí:
# /usr/local/dpc/bin/dpc status
Version: 19.9.0-13
msm-ui-main: active
msm-monitor: inactive
msm-elg: active
mongod: active
rabbitmq-server: activating
nginx: active
dp-iam: active
FIPS: disabled
# Protokol RabbitMQ zobrazuje chyby při přístupu k úložišti zpráv během spouštění. Například v dialogovém okně /var/log/dpc/rabbitmq/rabbit@<DPC Hostname>.log, zobrazuje se, že RabbitMQ selže při pokusu o opětovné sestavení indexu:
2024-05-07 23:56:25.408992-04:00 [info] <0.230.0> Running boot step recovery defined by app rabbit
2024-05-07 23:56:25.410137-04:00 [info] <0.423.0> Making sure data directory '/var/lib/dpc/rabbitmq/mnesia/rabbit@<DPC Hostname>/msg_stores/vhosts/628WB79CIFDYO9LJI6DKMI09L' for vhost '/' exists
2024-05-07 23:56:25.412199-04:00 [info] <0.423.0> Starting message stores for vhost '/'
2024-05-07 23:56:25.412425-04:00 [info] <0.428.0> Message store "628WB79CIFDYO9LJI6DKMI09L/msg_store_transient": using rabbit_msg_store_ets_index to provide index
2024-05-07 23:56:25.413720-04:00 [info] <0.423.0> Started message store of type transient for vhost '/'
2024-05-07 23:56:25.413970-04:00 [info] <0.432.0> Message store "628WB79CIFDYO9LJI6DKMI09L/msg_store_persistent": using rabbit_msg_store_ets_index to provide index
2024-05-07 23:56:25.414552-04:00 [warning] <0.432.0> Message store "628WB79CIFDYO9LJI6DKMI09L/msg_store_persistent": rebuilding indices from scratch
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0> ** Generic server <0.369.0> terminating
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0> ** Last message in was {'$gen_cast',
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0> {submit_async,
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0> #Fun<rabbit_classic_queue_index_v2.11.72031207>,
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0> <0.367.0>}}
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0> ** When Server state == undefined
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0> ** Reason for termination ==
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0> ** {function_clause,
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0> [{rabbit_queue_index,journal_minus_segment1,
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0> [{no_pub,no_del,ack},
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0> {{true,
2024-05-07 23:56:25.495894-04:00 [error] <0.369.0> <<136,59,154,30,244,191,111,192,154,235,124,189,92,104,1,207,
Cause
RabbitMQ se nepodaří spustit kvůli velkému množství zablokovaných zpráv ve frontě.
V tomto příkladu je ve frontě více než 800 MB dat:
V tomto příkladu je ve frontě více než 800 MB dat:
<DPC Hostname>:/var/lib/dpc/rabbitmq/mnesia # du -h . 20K ./rabbit@<DPC Hostname>/quorum/rabbit@<DPC Hostname> 20K ./rabbit@<DPC Hostname>/quorum 58M ./rabbit@<DPC Hostname>/msg_stores/vhosts/628WB79CIFDYO9LJI6DKMI09L/msg_store_persistent 824M ./rabbit@<DPC Hostname>/msg_stores/vhosts/628WB79CIFDYO9LJI6DKMI09L/queues/BV3H25N6AGWF7TDIN2L5RE0DA 824M ./rabbit@<DPC Hostname>/msg_stores/vhosts/628WB79CIFDYO9LJI6DKMI09L/queues 0 ./rabbit@<DPC Hostname>/msg_stores/vhosts/628WB79CIFDYO9LJI6DKMI09L/msg_store_transient 881M ./rabbit@<DPC Hostname>/msg_stores/vhosts/628WB79CIFDYO9LJI6DKMI09L 881M ./rabbit@<DPC Hostname>/msg_stores/vhosts 881M ./rabbit@<DPC Hostname>/msg_stores 20K ./rabbit@<DPC Hostname>/coordination/rabbit@<DPC Hostname> 20K ./rabbit@<DPC Hostname>/coordination 881M ./rabbit@<DPC Hostname> 0 ./rabbit@<DPC Hostname>-plugins-expand 881M . <DPC Hostname>:/var/lib/dpc/rabbitmq/mnesia #
Resolution
Chcete-li tento problém vyřešit, použijte níže uvedený postup k opětovnému sestavení prostředků RabbitMQ:
Příklad výstupu z testovacího prostředí:
- Pořiďte snapshot virtuálního počítače DPC nebo proveďte úplnou zálohu serveru DPC.
- Přihlaste se do DPC pomocí SSH a přihlaste se jako "admin" a poté změňte uživatele na uživatele root:
su -
- Zastavte službu RabbitMQ (
rabbitmq-server) pomocí následujícího příkazu:
service rabbitmq-server stop
- Změňte adresář na
/var/lib/dpc/rabbitmq/mnesia:
cd /var/lib/dpc/rabbitmq/mnesia
- Pokud je v nabídce dostatek volného místa
/tmpzkopírujte data do složky/tmp(volitelné):
cp -rp * /tmp
- Odebrat data v části
/var/lib/dpc/rabbitmq/mnesiapomocí následujícího příkazu:
rm -rf *
- Restartujte službu RabbitMQ, soubory v části
/var/lib/dpc/rabbitmq/mnesiaby měly být regenerovány:
service rabbitmq-server start
- Restartujte služby DPC:
/usr/local/dpc/bin/dpc restart
Příklad výstupu z testovacího prostředí:
Obrázek 1: Příklad znázorňující RabbitMQ, který regeneruje datovou strukturu v části
/var/lib/dpc/rabbitmq/mnesia Během spouštění
- Přihlaste se do uživatelského rozhraní DPC a ověřte, zda DPC funguje podle očekávání.
- Odstranění podsložek, do kterých byly dříve přesunuty
/tmppokud byla data zkopírována v kroku 5. - Jakmile se služba vrátí do normálního stavu, odstraňte snímek virtuálního počítače DPC , pokud byl pořízen.
Affected Products
Data Protection Central, PowerProtect DP4400, PowerProtect DP5300, PowerProtect DP5800, PowerProtect DP8300, PowerProtect DP8800, PowerProtect Data Protection Software, Integrated Data Protection Appliance Family
, Integrated Data Protection Appliance Software, PowerProtect DP5900, PowerProtect DP8400, PowerProtect DP8900
...
Article Properties
Article Number: 000225640
Article Type: Solution
Last Modified: 27 Jun 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.