Connectrix Cisco MDS: Der Vertrauenscode konnte nicht installiert werden, wenn der Switch direkt mit CSSM verbunden ist

Summary: Topologie 2: Direkt mit CSSM verbunden. Bei dieser Art von Verbindung wird die Kommunikation direkt und eine vertrauenswürdige Verbindung von einem Switch zum CSSM hergestellt. Für die direkte Verbindung ist eine Netzwerkerreichbarkeit mit CSSM erforderlich. Der Switch ist mit dem Transporttyp "Call Home" konfiguriert. ...

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Symptoms

Der installierte Vertrauenscode zeigt "<keinen>" an und der Status kann unter "Lizenzstatus anzeigen" nicht aktualisiert werden, ohne dass die Fehlermeldung "Protokollierungsprotokoll anzeigen" auftritt.
`show license status`
Utility: 
    Status: DISABLED

Smart Licensing using Policy:
    Status: ENABLED

Data Privacy: 
    Sending Hostname: yes 
    Callhome Hostname Privacy: DISABLED 
        Smart Licensing Hostname Privacy: DISABLED 
    Version Privacy: DISABLED 

Transport: 
    Type: Callhome
.
.
.
Trust Code installed: <none>  >> The trust code status shows none.

Cause

CSSM ist nicht erreichbar und der konfigurierte Transporttyp ist CallHome.
Verwenden Sie den folgenden Befehl, um zu überprüfen, ob die URL genau wie folgt konfiguriert ist: https://tools.cisco.com/its/service/oddce/services/DDCEService.

 show license status

 

Switch : san002
callhome
  email-contact <Company email ID>
  streetaddress <Site address>
  distribute
  destination-profile full_text
  destination-profile full_text format XML
  destination-profile full_text message-size 100000
  destination-profile test
  destination-profile test format XML
  destination-profile test message-level 5
  destination-profile xml transport-method http
  destination-profile xml message-level 2
  .
  .
  .
  destination-profile xml http https://tools.cisco.com/its/service/oddce/services/DDCEService > this URL configuraion should be present in callhome config.
  destination-profile test alert-group system
  transport email from <Company email ID>
  transport email reply-to <Company email ID>

Resolution

Konfigurieren Sie die URL und überprüfen Sie die mit der URL aktualisierte Call Home-Konfiguration.
switch# configure terminal
switch(config)# ip domain-lookup
switch(config)# ip domain-name cisco.com
switch(config)# ip name-server 171.70.xx.xx
switch(config)# callhome
switch(config-callhome)# dest xml trans http
switch(config-callhome)# dest xml email sl-sch-test@cisco.com
switch(config-callhome)# dest xml http https://tools.cisco.com/its/service/oddce/services/DDCEService
switch(config-callhome)# enable
switch(config-callhome)# commit*
switch(config-callhome)# exit
switch(config)# feature license smart
Stellen Sie sicher, dass der CallHome-Verteiler aktiviert ist. Andernfalls schlägt der Commit fehl.
Sobald die URL konfiguriert ist, installieren Sie den Vertrauenscode mithilfe der folgenden Methode: 
Führen Sie den folgenden Befehl auf dem Switch aus:
switch# license smart trust idtoken id_token_value all
Das ID-Token sollte aus dem CSSM-Portal auf der Registerkarte "Inventory>General" kopiert werden.
san002# show license status
Utility:
    Status: DISABLED
Smart Licensing using Policy:
    Status: ENABLED
Data Privacy:
    Sending Hostname: yes
    Callhome Hostname Privacy: DISABLED
        Smart Licensing Hostname Privacy: DISABLED
    Version Privacy: DISABLED
Transport:
    Type: Callhome
.
.
.
Trust Code installed: Sep  2 13:10:07 2024  UTC
    Active: PID: DS-C9706, SN: FXS24XXXXXX
        Sep  2 13:10:07 2024  UTC
    Standby: PID: DS-C9706, SN: FXS24XXXXXX
        Sep  2 13:10:07 2024  UTC

Additional Information

Products

Connectrix MDS-Series Firmware
Article Properties
Article Number: 000228278
Article Type: Solution
Last Modified: 16 Sept 2024
Version:  1
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