Data Domain: Lösa GUI-problem med värdnamn

Summary: DD System Manager fungerar inte med DD-värdnamn i Data Domain GUI. Problemet uppstår när du försöker komma åt det grafiska användargränssnittet med värdnamnet, vilket resulterar i ett 400-fel, medan åtkomst med IP-adressen inte orsakar några problem. Problemet är relaterat till värdnamnsformatet, särskilt användningen av ett understreck, vilket inte är tillåtet i domännamn. Problemet löstes genom att värdnamnet uppdaterades till ett giltigt format, certifikaten återskapades och DNS-posterna uppdaterades. Kunden kunde läsa in det grafiska användargränssnittet efter dessa ändringar. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Kunden har problem med att Data Domain GUI inte fungerar med värdnamnet.

  • När du ansluter till det grafiska användargränssnittet med värdnamnet får kunden ett 400-fel, vilket är ett fel på klientsidan.
  • Men när du kommer åt GUI med IP-adressen är det inga problem.
  • Åtkomst till CLI via Putty med både värdnamnet och IP-adressen fungerar bra.

Cause

Rotorsaken till problemet är relaterat till det värdnamnsformat som används av kunden.

  • Värdnamnet innehåller ett understreck (_), vilket inte är ett giltigt tecken i ett domännamn.
  • Detta orsakar ett fel i Apache Tomcat-loggarna, särskilt felmeddelandet "Tecknet [_] är aldrig giltigt i ett domännamn".
  • Felet uppstår när kunden försöker få åtkomst till det grafiska användargränssnittet med hjälp av värdnamnet, vilket resulterar i ett 400-fel.
  • Värdnamnet får bara vara 63 tecken långt

Viktigt! Om du använder ett understreck i värdnamnet kan det orsaka problem med det grafiska användargränssnittet och kan kräva att certifikat återskapas.

Relevanta felmeddelanden och koder:

  • Fel på Apache Tomcat-logg: "Tecknet [_] är aldrig giltigt i ett domännamn."
  • HTTP-felkod: 400 (felaktig begäran)

Resolution

Följ anvisningarna nedan för att lösa problemet:

  1. Uppdatera värdnamnet: Uppdatera värdnamnet för Data Domain till ett giltigt värdnamn utan understreck. Detta kan göras från det grafiska användargränssnittet (med hjälp av IP-adressen) genom att följa stegen som nämns i administrationsguiden.
  2. Återskapa certifikaten: När du har uppdaterat värdnamnet återskapar du certifikaten. Detta säkerställer att HTTPS-certifikatet uppdateras med det nya värdnamnet.
  3. Uppdatera DNS-poster: Uppdatera DNS-posterna så att de återspeglar det nya värdnamnet. Detta säkerställer att peer-replikeringssystemet kan fortsätta att matcha det nya värdnamnet.
  4. Ändra replikering: Ändra replikeringskonfigurationen så att det nya värdnamnet används.
  5. Kontrollera problemet: Kontrollera att problemet har lösts genom att öppna det grafiska användargränssnittet med det nya värdnamnet. Om problemet kvarstår kontaktar du Dells support för ytterligare hjälp.
  6. Alla ovanstående steg dokumenteras i denna KB: https://www.dell.com/support/kbdoc/en-us/000056665/89823-changing-data-domain-hostname

Viktigt! Om du inte känner dig bekväm med att ändra replikeringskonfigurationen rekommenderar vi att du kontaktar Dells support för hjälp.
Not: Det är viktigt att uppdatera DNS-posterna och återskapa certifikaten för att säkerställa att peer-replikeringssystemet kan fortsätta matcha det nya värdnamnet.

Affected Products

Data Domain
Article Properties
Article Number: 000229461
Article Type: Solution
Last Modified: 19 Dec 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.