Data Domain. Устранение проблем с именем хоста в графическом интерфейсе пользователя

Summary: DD System Manager не работает с именем хоста DD в графическом интерфейсе Data Domain. Эта проблема возникает при попытке доступа к графическому интерфейсу пользователя с использованием имени хоста, что приводит к ошибке 400, в то время как доступ с помощью IP-адреса не вызывает никаких проблем. Проблема связана с форматом имени хоста, в частности, с использованием символа подчеркивания, который не допускается в доменных именах. Проблема была устранена путем обновления имени хоста до допустимого формата, повторного создания сертификатов и обновления записей DNS. После этих изменений заказчик смог успешно загрузить графический интерфейс пользователя. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

У заказчика возникла проблема, связанная с тем, что графический интерфейс пользователя Data Domain не работает с именем хоста.

  • При подключении к графическому интерфейсу пользователя с именем хоста клиент получает ошибку 400, которая является ошибкой на стороне клиента.
  • Однако при доступе к графическому интерфейсу пользователя с помощью IP-адреса проблем не возникает.
  • Доступ к CLI через Putty с именем хоста и IP-адресом работает нормально.

Cause

Корневая причина проблемы связана с форматом имени хоста, используемым клиентом.

  • Имя хоста содержит символ подчеркивания (_), который не является допустимым символом в имени домена.
  • Это приводит к ошибке в журналах Apache Tomcat, в частности, к сообщению об ошибке «Символ [_] никогда не действителен в доменном имени».
  • Ошибка возникает, когда пользователь пытается получить доступ к графическому интерфейсу пользователя с помощью имени хоста, что приводит к ошибке 400.
  • Имя хоста может состоять только из 63 символов

Внимание! Использование символа подчеркивания в имени хоста может вызвать проблемы с графическим интерфейсом пользователя и может потребовать повторной генерации сертификатов.

Соответствующие сообщения об ошибках и коды:

  • Ошибка журнала Apache Tomcat: «Символ [_] никогда не является допустимым в имени домена».
  • Код ошибки HTTP: 400 (недопустимый запрос)

Resolution

Для устранения этой неполадки выполните следующие действия.

  1. Обновите имя хоста: Обновите имя хоста Data Domain на действительное имя хоста без подчеркиваний. Это можно сделать из графического интерфейса пользователя (с помощью IP-адреса), выполнив действия, описанные в руководстве по администрированию.
  2. Повторное создание сертификатов: После обновления имени хоста повторно создайте сертификаты. Это обеспечит обновление сертификата HTTPS новым именем хоста.
  3. Обновление записей DNS: Обновите записи DNS, чтобы отразить новое имя хоста. Это будет гарантировать, что одноранговая система репликации сможет продолжить разрешать новое имя хоста.
  4. Изменение репликации: Измените конфигурацию репликации, чтобы использовать новое имя хоста.
  5. Убедитесь, что проблема не устранена: Убедитесь, что проблема устранена, перейдя к графическому интерфейсу пользователя с новым именем хоста. Если проблема не устранена, обратитесь в службу поддержки Dell для получения дополнительной помощи.
  6. Все вышеперечисленные действия описаны в статье базы знаний: https://www.dell.com/support/kbdoc/en-us/000056665/89823-changing-data-domain-hostname

Внимание! Если вы не хотите вносить изменения в конфигурацию репликации, рекомендуется обратиться за помощью в службу поддержки Dell.
Заметка: Крайне важно обновить записи DNS и повторно создать сертификаты, чтобы одноранговая система репликации могла продолжать разрешать новое имя хоста.

Affected Products

Data Domain
Article Properties
Article Number: 000229461
Article Type: Solution
Last Modified: 19 Dec 2024
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.