PowerStore 9000T: La modifica della memoria del container NAS causa il riavvio del nodo dopo l'aggiornamento a v4.0.0.x
Summary: Durante un aggiornamento da PowerStoreOS 3.5.x o 3.6.x a PowerStoreOS v4.0.1.0 , v4.0.1.1 o v4.1.x, il limite di memoria del NAS interno non è impostato correttamente. Ciò potrebbe causare una condizione di memoria insufficiente e il conseguente riavvio del container NAS. ...
Symptoms
Nel cluster PowerStore potrebbero verificarsi riavvii imprevisti dei nodi.
In rari scenari, entrambi i nodi potrebbero riavviarsi contemporaneamente, con conseguente temporanea non disponibilità dei dati.
Il problema riguarda solo:
- Modelli PowerStore 9000T configurati in modalità unificata.
- Tutti gli altri modelli e i sistemi solo blocco non sono interessati.
- Cluster aggiornati dalle versioni 3.5 o 3.6 di PowerStoreOS alle versioni 4.0.1.0. v4.0.1.1 o v4.1.0.x
- I sistemi forniti con la versione 4.0 preinstallata non sono interessati.
Nota: Questo problema viene rilevato dal off_release_sdnas_memory_config Pre Upgrade Health Check (PUHC). Per ulteriori informazioni su questo PUHC, consultare KB# 000250803 PowerStore: Controllo integrità pre-aggiornamento (PUHC) per rilevare un problema di configurazione della memoria SDNAS
Cause
Questo problema è il risultato di un ribilanciamento dei limiti di allocazione della memoria tra i servizi NAS e la piattaforma sottostante in PowerStore versione 4.0.
È possibile che si verifichi una mancata corrispondenza tra il limite della piattaforma per il contenitore NAS e quello che il NAS tenta di allocare internamente. Ciò potrebbe causare il raggiungimento del limite di memoria della piattaforma e l'attivazione di un riavvio del servizio NAS per risolvere il problema.
Questo limite può essere raggiunto ripetutamente, causando più riavvii del servizio NAS, fino a quando il limite di allocazione della memoria per il servizio NAS non viene fisso.
Resolution
Questo problema è stato risolto in PowerStoreOS versione 4.0.1.2 (o successiva).
Soluzione alternativa
Con le versioni precedenti, contattare il supporto tecnico Dell o il responsabile dell'assistenza autorizzato e citare l'ID di questo articolo della Knowledge Base.