Avamar: Backup Does Not Change Status from Marked to Cloud

Summary: This article addresses the issue where Avamar backups do not change from "Marked" to "Cloud" after data movement. The problem occurs because the updatebackuprecs parameter is set to false by default. Confirm this behavior using the Avamar Web Console, Administrator Console, or command-line. To resolve, contact Dell support or manually restart the Avamar server with the expert flag, ensuring the updatebackuprecs parameter is set to true. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Data movement completed but the Avamar backups remain with Tier "Marked" instead of "Cloud."

This behavior is observed using Avamar User Interface (AUI) or Administrator Console or command-line:

mccli backup show --name=/domain/client_name
admin@av-server:~/>: mccli backup show --name=/vc-4400.lab.com/VirtualMachines/Client_Name
0,23000,CLI command completed successfully.
Created             LabelNum Size     Retention Hostname          Location Consistent Level Tier
------------------- -------- -------- --------- ----------------- -------- ---------------- ------
2024-07-01 07:49 PM 3        118.6 GB DM        av-server.lab.com Local    file             Marked
2024-06-01 07:48 PM 2        118.6 GB DM        av-server.lab.com Local    file             Marked
2024-05-03 04:47 PM 1        118.6 GB DWMY      av-server.lab.com Local    file             Marked
admin@av-server:~/>:
avmgr getb --format=xml --path=/domain/client_name
admin@av-server:~/>: avmgr getb --format=xml --path=/vc-4400.lab.com/VirtualMachines/Client_Name_GpL03kZpMiWvgZnLD3ZMjw
1  Request succeeded
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<backuplist version="3.0">
  <backuplistrec flags="18087937" labelnum="3" label="Group_Backup-1" created="1720136998" roothash="3a1f5cc0326478bea0d37f4e74ee2f05b84cbcf7" totalbytes="127339102208.00" ispresentbytes="0.00" pidnum="1016" percentnew="0" expires="1722728700" created_prectime="0x1dace6ce0b584e6" partial="0" retentiontype="daily,monthly" backuptype="Full" ddrindex="1" locked="1" direct_restore="1" tier="1" appconsistent="file" sealstate="COMPLETE"/>
  <backuplistrec flags="17825793" labelnum="2" label="Group_Backup-1" created="1717238893" roothash="35b7ad90df2f30697c34fb80e2ef52eeee63a4df" totalbytes="127339102208.00" ispresentbytes="0.00" pidnum="1016" percentnew="0" expires="1722642300" created_prectime="0x1dacda37703e368" partial="0" retentiontype="daily,monthly" backuptype="Full" ddrindex="1" locked="0" direct_restore="1" tier="1" appconsistent="file" sealstate="COMPLETE"/>
  <backuplistrec flags="32505857" labelnum="1" label="Group_Backup-1" created="1714722433" roothash="7861266b13311248fb95876532e45b0b0b2051af" totalbytes="127339102208.00" ispresentbytes="0.00" pidnum="1016" percentnew="2" expires="1722630736" created_prectime="0x1dacd8a29ca77d8" partial="0" retentiontype="daily,weekly,monthly,yearly" backuptype="Full" ddrindex="1" locked="0" direct_restore="1" tier="1" appconsistent="file" sealstate="COMPLETE"/>
</backuplist>
admin@av-server:~/>:

Tier explanation:

  • Tier 0 is Active tier, meaning on the server locally;
  • Tier 1 is Marked for movement to cloud tiering device, but still local;
  • Tier 2 is Migration complete, meaning data is stored on a Cloud tiering device;
  • Tier 3 is Migration in progress

Expected behavior after data movement completed is:

admin@av-server:~/>: mccli backup show --name=/vc-4400.lab.com/VirtualMachines/Client_Name
0,23000,CLI command completed successfully.
Created             LabelNum Size     Retention Hostname          Location Consistent Level Tier
------------------- -------- -------- --------- ----------------- -------- ---------------- ------
2024-07-01 07:49 PM 3        118.6 GB DM        av-server.lab.com Local    file             Cloud
2024-06-01 07:48 PM 2        118.6 GB DM        av-server.lab.com Local    file             Cloud
2024-05-03 04:47 PM 1        118.6 GB DWMY      av-server.lab.com Local    file             Cloud
admin@av-server:~/>:
admin@av-server:~/>: avmgr getb --format=xml --path=/vc-4400.lab.com/VirtualMachines/Client_Name_GpL03kZpMiWvgZnLD3ZMjw
1  Request succeeded
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<backuplist version="3.0">
  <backuplistrec flags="18087937" labelnum="3" label="Group_Backup-1" created="1720136998" roothash="3a1f5cc0326478bea0d37f4e74ee2f05b84cbcf7" totalbytes="127339102208.00" ispresentbytes="0.00" pidnum="1016" percentnew="0" expires="1722728700" created_prectime="0x1dace6ce0b584e6" partial="0" retentiontype="daily,monthly" backuptype="Full" ddrindex="1" locked="1" direct_restore="1" tier="2" appconsistent="file" sealstate="COMPLETE"/>
  <backuplistrec flags="17825793" labelnum="2" label="Group_Backup-1" created="1717238893" roothash="35b7ad90df2f30697c34fb80e2ef52eeee63a4df" totalbytes="127339102208.00" ispresentbytes="0.00" pidnum="1016" percentnew="0" expires="1722642300" created_prectime="0x1dacda37703e368" partial="0" retentiontype="daily,monthly" backuptype="Full" ddrindex="1" locked="0" direct_restore="1" tier="2" appconsistent="file" sealstate="COMPLETE"/>
  <backuplistrec flags="32505857" labelnum="1" label="Group_Backup-1" created="1714722433" roothash="7861266b13311248fb95876532e45b0b0b2051af" totalbytes="127339102208.00" ispresentbytes="0.00" pidnum="1016" percentnew="2" expires="1722630736" created_prectime="0x1dacd8a29ca77d8" partial="0" retentiontype="daily,weekly,monthly,yearly" backuptype="Full" ddrindex="1" locked="0" direct_restore="1" tier="2" appconsistent="file" sealstate="COMPLETE"/>
</backuplist>
admin@av-server:~/>:

 

Cause

The updatebackuprecs parameter is set to false. The default value is true.

Confirm the parameter value:

admin@av-server:~/>: cat /data01/cur/gsan.opt |grep -Eo 'updatebackuprecs.{0,8}'
updatebackuprecs="false"
admin@av-server:~/>:

Or

admin@av-server:~/>: grep updatebackuprecs /usr/local/avamar/var/nodelist.xml
      updatebackuprecs="false"
admin@av-server:~/>:

 

Resolution

Contact Dell support to restart the Avamar server with expert flag.

 

Affected Products

Avamar Server

Products

Avamar
Article Properties
Article Number: 000230649
Article Type: Solution
Last Modified: 03 Dec 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.