PowerStore: Das Hochladen eines von einer öffentlichen PKI signierten HTTP-Managementzertifikats schlägt fehl
Summary: Das Hochladen eines signierten Zertifikats in PowerStore führt zu Fehlern: Zertifikat konnte im Zugangsdatenspeicher nicht aktualisiert werden. Überprüfen Sie Ihre Zertifikatkette (0xE09010010013) und das Zertifikat enthält kein SAN mit IP-Adresse oder DNS-Name (0xE090A0010009). ...
Symptoms
Failed to update certificate in credential store. Please verify your certificate chain (0xE09010010013).
Certificate does not contain SAN with IP address or DNS name (0xE090A0010009).
Abbildung des Fehlers 0xE09010010013:
Abbildung des Fehlers 0xE090A0010009:
Cause
Wenn es um PKI geht, lassen sie in der Regel keine IP-Adressen im SAN für öffentliche Zertifikate zu. Öffentliche PKI stellen in der Regel Zertifikate aus, die für öffentliche Domänen oder Webserver bestimmt sind.
Private PKI ist in der Regel in der Lage, Zertifikate mit SAN zu erzeugen, die eine beliebige Anzahl von IPv4-Adressen, IPv6-Adressen und vollständig qualifizierten Domänennamen (FQDN) enthalten. Sie dienen dazu, Zertifikatsdienste organisationsintern (Intranet) und nicht für die Öffentlichkeit (Internet) bereitzustellen.
Resolution
Überprüfen Sie, ob das SAN die Cluster-IPv4-Adresse, die IPv6-Adresse und den DNS-Namen des PowerStore enthält.
Suchen Sie diese Informationen mit einer der folgenden Methoden:
- Im Microsoft Certificate Utility:
.crt oder .pem Erweiterung. Verwenden Sie in der Eingabeaufforderung oder PowerShell certutil.exe:
certutil.exe -dump CertificateName.pem
- In einer Linux-Shell mit OpenSSL:
openssl x509 -in certificateName.pem -text -noout
Wenn das SAN nicht über alle drei erforderlichen Felder verfügt, wenden Sie sich an Ihren Zertifikatanbieter und fordern Sie die Signierung des Zertifikats an, und stellen Sie sicher, dass alle erforderlichen Informationen enthalten sind. Wenn sie kein Zertifikat mit diesen Informationen bereitstellen können, müssen Sie diese Zertifikate über einen privaten PKI-Anbieter generieren oder eine lokale PKI erstellen, die diese Zertifikate signieren kann.
Wenn weiterhin Probleme vorliegen und alle Zertifikatinformationen korrekt angezeigt werden, können Sie sich an den Dell Support wenden, um Unterstützung bei dem Zertifikatproblem zu erhalten.