Connectrix Cisco NDFC: Reset Baseline Configuration for switch by NDFC the configuration drift does not reset
Summary: "Reset Baseline Configuration" for switch by NDFC the configuration drift does not reset.
Symptoms
The NDFC upgraded from 3.1.1k to 3.2.1i.
The NDFC failed to update the IP address changes for the switches.
Cause
If the IP address changes on the switches were initiated, the configuration drift in Nexus Dashboard Fabric Controller (NDFC) might fail to identify the correct IP address for a switch and could still be pointing to the old IP.
This can happen because NDFC relies on the initial discovery IP address for managing and monitoring the switches.
When the IP address changes, the NDFC may not automatically update its records, leading to discrepancies.
The events could be observed in the NDFC sanconfig_cache_dump files. Check the IPs listed for the switch serial number.
Alert from NDFC user interface:

Resolution
To clear the configuration drift on the NDFC, go ahead and perform the below steps:
Check Fabric dashboard -> select the Fabric -> Actions -> Purge Fabrics (The purge action removes the entry for old switch IP):
Example:

Now go to the Fabric dashboard -> Configuration Monitor -> Actions -> Disable Fabric Monitoring.
Fabric dashboard -> Configuration Monitor -> Actions -> Enable Fabric Monitoring.
Example:

The stale switch IP entry has been removed and replaced with a new entry, post which the reset baseline on NDFC works with no issues.
Additional Information
The file "sanconfig_cache_dump" can be found under the NDFC logs "\cisco-ndfc-dcnm-apps-logs\dcnm-san-config"