Příkazy PowerFlex SCLI selžou s chybou "Invalid session"

Summary: Příkazy SCLI selžou s chybou "Invalid session".

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Scénář

Zákazník má jednu z následujících možností:

  • Monitorovací software nebo skripty třetích stran, které k MDM pravidelně odesílají přihlašovací údaje scli. 

A možná: 

  • MDM proměnné "user_session_hard_timeout_secs" nebo "user_session_timeout_secs" jsou nastaveny nad výchozími hodnotami.

Příznaky

Zde lze pozorovat dva příznaky:

  1. Příkazy SCLI selžou s následující chybou:
Error: MDM failed command. Status: Invalid session. Please login and try again.

2 – Pokusy o přihlášení selžou s následující chybou:

cli --login --username dave@local.net --ldap_authentication
Enter password:
Error: MDM failed command. Status: A timeout occurred

 

Důsledky

Nelze se správně přihlásit a nelze provést konfiguraci systému ScaleIO.

Cause

Pokud jsou hodnoty "user_session_hard_timeout_secs" nebo "user_session_timeout_secs" nastaveny nad výchozí hodnoty a monitorovací skript nebo program se opakovaně přihlašuje, může se tabulka přihlašovacích relací MDM zaplnit ještě před úplným vypršením časového limitu první relace. Když je tabulka relace plná, přihlášení proběhne úspěšně, ale není k dispozici žádné ID relace a příkazy selžou.

Resolution

Zástupné řešení

Pro tento problém je k dispozici několik oprav:

  1. Vyhledejte uživatele nebo službu, která se opakovaně přihlašuje, zastavte přihlášení a počkejte 10 minut (výchozí časový limit nečinnosti)
  2. Pokud uživatele/službu nelze zastavit z jiných důvodů, prodlužte dobu jejího intervalu přihlašování
  3. Pokud to není možné, můžete časový limit relace uživatele zkrátit. Výchozí hodnota je 10 minut. Viz dokumentace zde, str. 452.

NEBO

  1. V hlavním uzlu MDM spusťte příkaz scli --query_cluster a ověřte, že stav clusteru MDM je Normal.

  2. Na podřízeném MDM: Odeberte (nebo zakomentujte) následující dvě proměnné, pokud jsou přítomny, v mdm/cfg/conf.txt v obou MDM: 

user_session_hard_timeout_secs= (default 8 hrs)
user_session_timeout_secs= (default 10 mins)

3 – Restartujte službu MDM:

  kill <mdm pid>

4- Opakujte výše uvedené kroky pro každý podřízený MDM.

5 – Přepněte vlastnictví MDM na jeden z podřízených MDM.

6 – Ověřte, že stav clusteru MDM je Normal, a poté spusťte kroky 2 ~ 3 na předchozím hlavním uzlu MDM.

7 – Počkejte 10 minut a poté zkuste znovu spustit příkazy scli po přihlášení.

 

Dotčené verze

1.32.x 2.x 

Opraveno ve verzi

 3.x

Article Properties
Article Number: 000281724
Article Type: Solution
Last Modified: 06 Feb 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.