PowerFlex Scli-kommandoer mislykkes med "Invalid session"

Summary: Scli-kommandoer mislykkes med «Ugyldig økt».

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Scenario

Kunden har ett av følgende:

  • Tredjeparts overvåkingsprogramvare eller skript som utsteder periodiske SCLI-pålogginger mot MDM. 

Og muligens: 

  • MDM-variablene "user_session_hard_timeout_secs" eller "user_session_timeout_secs" er angitt ovenfor standard.

Symptomer

To symptomer kan observeres her:

  1. Scli-kommandoer mislykkes med følgende feil:
Error: MDM failed command. Status: Invalid session. Please login and try again.

2 – Påloggingsforsøk mislykkes med følgende feilmelding:

cli --login --username dave@local.net --ldap_authentication
Enter password:
Error: MDM failed command. Status: A timeout occurred

 

Innvirkning

Kan ikke logge ordentlig inn og ingen konfigurasjon kan gjøres til ScaleIO.

Cause

Når "user_session_hard_timeout_secs" eller "user_session_timeout_secs" er angitt over standardverdiene og et overvåkingsskript/program logger på gjentatte ganger, kan tabellen for MDM-påloggingsøkten bli full før det harde tidsavbruddet inntreffer for den første økten. Når økttabellen er full, lykkes påloggingen, men ingen økt-ID er tilgjengelig og kommandoer mislykkes.

Resolution

Omgåelse av problemet

Det er et par rettelser for dette problemet:

  1. Finn brukeren/tjenesten som logger på gjentatte ganger, og stopp deretter påloggingene og vent i 10 minutter (standard tidsavbrudd for inaktiv bruk)
  2. Dersom brukeren/tjenesten ikke kan stoppes av andre grunner, øk innloggingsintervalltiden
  3. Hvis dette ikke er mulig, kan du redusere tidsavbruddet for brukerøkten. Standard er 10 minutter. Se dokumentasjonen her, side 452.

ELLER

  1. Kjør fra Master MDM scli --query_cluster og kontroller at MDM-klyngetilstanden er Normal.

  2. På en slave MDM: Fjern (eller kommenter) følgende to variabler, hvis de finnes, i mdm/cfg/conf.txt på begge MDM-ene: 

user_session_hard_timeout_secs= (default 8 hrs)
user_session_timeout_secs= (default 10 mins)

3 – Start MDM-tjenesten på nytt:

  kill <mdm pid>

4- Gjenta trinnene ovenfor for hver slave MDM.

5 – Bytt MDM-eierskap til en av de underdannede MDM-ene

6 – Kontroller at MDM-klyngetilstanden er Normal, og kjør deretter trinn 2 ~ 3 på forrige hoved-MDM.

7 – Vent i 10 minutter, og prøv deretter å utstede scli-kommandoer på nytt etter innlogging.

 

Berørte versjoner

1.32.x 2.x 

Løst i versjon

 3.x

Article Properties
Article Number: 000281724
Article Type: Solution
Last Modified: 06 Feb 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.