PowerFlex Scli 命令失敗並顯示「無效的工作階段」
Summary: Scli 命令失敗,並顯示「無效的會話」。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
案例
客戶有下列其中一項:
- 第三方監控軟體或指令檔會針對 MDM 定期發出 SCLI 登入。
並且可能:
- MDM 變數「user_session_hard_timeout_secs」或「user_session_timeout_secs」設定高於預設值。
症狀
這裡可以觀察到兩種癥狀:
-
Scli 命令失敗,並出現以下錯誤:
Error: MDM failed command. Status: Invalid session. Please login and try again.
2- 登入嘗試失敗,並出現下列錯誤:
cli --login --username dave@local.net --ldap_authentication Enter password: Error: MDM failed command. Status: A timeout occurred
影響
無法正確登入,且無法對 ScaleIO 進行任何設定。
Cause
當「user_session_hard_timeout_secs」或「user_session_timeout_secs」設定高於預設值,且監控指令檔/程式重複登入時,MDM 登入工作階段表格可能會在第一個工作階段發生硬性逾時之前變滿。當會話表已滿時,登錄成功,但沒有會話標識可用,命令將失敗。
Resolution
因應措施
此問題有幾個修復程式:
- 找到重複登入的使用者/服務,然後停止登入並等待 10 分鐘 (預設閒置逾時)
- 如果使用者/服務因其他原因無法停止,請增加其登錄間隔時間
- 如果無法做到這一點,您可以縮短用戶會話超時。預設值為 10 分鐘。請參閱此處的文檔,第 452 頁。
或
-
從主 MDM 開始,執行
scli --query_cluster並確保 MDM 叢集狀態為正常。 -
在從屬 MDM 上:在兩個 MDM 的 mdm/cfg/conf.txt中移除 (或註解) 下列兩個變數 (若有):
user_session_hard_timeout_secs= (default 8 hrs) user_session_timeout_secs= (default 10 mins)
3- 重新啟動 MDM 服務:
kill <mdm pid>
4- 為每個從屬 MDM 重複上述步驟。
5- 將 MDM 擁有權切換至其中一個從屬 MDM
6- 確定 MDM 叢集狀態為「正常」,然後在上一個主 MDM 上執行步驟 2 ~ 3。
7-等待 10 分鐘,然後在登錄後再次嘗試發出 scli 命令。
受影響的版本
1.32.x 2.x
已修正問題的版本
3.x
Article Properties
Article Number: 000281724
Article Type: Solution
Last Modified: 06 Feb 2025
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.