PowerFlex Scli 命令失败,并显示“Invalid session”
Summary: Scli 命令失败,并显示“无效会话”。
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Symptoms
情况说明
客户具有以下情况之一:
- 针对 MDM 发出定期 scli 登录命令的第三方监视软件或脚本。
并且可能:
- MDM 变量“user_session_hard_timeout_secs”或“user_session_timeout_secs”设置为高于默认值。
症状
在这里可以观察到两个症状:
-
Scli 命令失败并显示以下错误:
Error: MDM failed command. Status: Invalid session. Please login and try again.
2- 登录尝试失败并显示以下错误:
cli --login --username dave@local.net --ldap_authentication Enter password: Error: MDM failed command. Status: A timeout occurred
影响
无法正确登录,也无法对 ScaleIO 进行配置。
Cause
如果“user_session_hard_timeout_secs”或“user_session_timeout_secs”设置为高于默认值,并且监视脚本/程序反复登录,则在第一个会话发生硬性超时之前,MDM 登录会话表可能会变满。当会话表已满时,登录成功,但没有可用的会话 ID,命令将失败。
Resolution
解决方法
此问题有几个修复程序:
- 找到重复登录的用户/服务,然后停止登录并等待 10 分钟(默认空闲超时)
- 如果由于其他原因无法停止用户/服务,请增加其登录间隔时间
- 如果无法做到这一点,您可以缩短用户会话超时。默认值为 10 分钟。请参阅此处的文档,第 452 页。
或者
-
从主 MDM 中,运行
scli --query_cluster并确保 MDM 群集状态为 Normal。 -
在从属 MDM 上:删除(或注释)两个 MDM 上的 mdm/cfg/conf.txt 中的以下两个变量(如果存在):
user_session_hard_timeout_secs= (default 8 hrs) user_session_timeout_secs= (default 10 mins)
3- 重新启动 MDM 服务:
kill <mdm pid>
4- 对每个从属 MDM 重复上述步骤。
5- 将 MDM 所有权切换到其中一个从属 MDM
6- 确保 MDM 群集状态为“正常”,然后在上一个主 MDM 上运行步骤 2 ~ 3。
7 - 等待 10 分钟,然后在登录后再次尝试发出 scli 命令。
受影响的版本
1.32.x 和 2.x
已修复问题的版本
3.x
Article Properties
Article Number: 000281724
Article Type: Solution
Last Modified: 06 Feb 2025
Version: 1
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