Connectrix B-Series: Flash Filling When Using Inline SSH Command to Pull Supportsave Logs

Summary: A potential issue when using inline SSH to collect a supportsave can overfill the file system.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Flash overfilling when the inline command is used to generate the supportsave logs.

Cause

Is it technically possible to use the following methods to collect a supportsave and is this recommended?

  • Use an inline SSH command to collect a supportsave by the following:
ssh admin@xx..xx.xx.xx supportsave -u user_name -h host_ip -d remote_dir -t timeout -l protocol -b 22 -n
  • Use Plink (a windows tool to automate SSH connections) to collect a supportsave by the following:
C:\>plink -v -batch -l admin xx.xx.xx.xx -pw password "supportsave -nc"

Resolution

It is not recommended to use an inline SSH command to collect the supportsave

For example:
If the SSH connection is lost or interrupted during the supportsave collection, then a SIGPIPE storm can occur where many SIGPIPE signals are triggered in a short period of time. This can lead to a rapid accumulation of logging, potentially causing disk space exhaustion (reaching 100%) which disrupts operations.

Affected Products

Connectrix B-Series Hardware
Article Properties
Article Number: 000306301
Article Type: Solution
Last Modified: 30 Apr 2025
Version:  1
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