PowerFlex 5.X: L'operazione Update Device Path è stata rimossa dall'interfaccia utente

Summary: A partire da PowerFlex Management Platform (PFMP) versione 5.x, nota anche come Erasure Coding (EC), l'opzione per utilizzare Update Device Path dall'interfaccia utente viene rimossa, come in tutte le versioni future. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Prima di PowerFlex 5.x, l'opzione per Update Device Path è stato eseguito utilizzando l'interfaccia utente PFMP:

  1. Go to Storage System>Devices Screen
  2. VAI a More Actions >Update Device Path

Percorso del dispositivo di aggiornamento PowerFlex

 

Impatto: Nessuna opzione per aggiornare il percorso del dispositivo utilizzando l'interfaccia utente PFMP.

Cause

Nel dispiegamento CE, il Update Device Path non è supportato e viene rimosso dall'interfaccia utente.

Resolution

Caso d'uso:

  1. Identificare il disco e il nodo.
  2. Provare a cancellare l'errore del dispositivo e attendere l'avvio della ricostruzione.
  3. Se l'errore persiste, sostituire il disco: 
    1. Rimuovere il disco da CloudLink (crittografia), se applicabile.
    2. Rimuovere il disco dalla configurazione del controller RAID, se applicabile.   
    3. Rimuovere il disco dai PowerFlex Distributed Capacity Services. La rimozione deve essere immediata, poiché PowerFlex la considera non riuscita.
    4. Far lampeggiare il disco e rimuoverlo fisicamente dal nodo.
    5. Aggiungere fisicamente il nuovo disco al nodo.
    6. Configurazione di RAID 0 nel controller RAID, se applicabile.
    7. Configurare CloudLink, se applicabile.
    8. Aggiungi a DGWT (Device Gateway Target): 
      1. Il percorso del dispositivo nel sistema operativo è /dev/sdb
      2. Il percorso del dispositivo originale di un altro disco nella DGWT è impostato come /dev/sdb anch'io add device fails
      3. Aggiornare il percorso del dispositivo utilizzando una delle seguenti opzioni:
        Utilizzando questo comando dell'interfaccia della riga di comando (SCLI) di ScaleIO:
scli --update_device_original_paths

Utilizzando la chiamata API (Application Programming Interface):

POST /api/instances/Node::<node ID>/action/updateNodeOriginalPathnames
{ "forceFailedDevices" :true //Optional - default false }
  1. Riprovare ad aggiungere il dispositivo add device successful
Article Properties
Article Number: 000370757
Article Type: Solution
Last Modified: 09 Dec 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.