[PowerScale] Węzły SED nie uruchamiają się z błędami SED po uaktualnieniu do OneFS 9.5 z wersji starszej niż 9.2
Summary: Kiedy węzły SED są uaktualniane bezpośrednio do OneFS 9.5 z wersji OneFS starszej niż 9.2, węzły nie uruchamiają się całkowicie, a dyski są wyświetlane w stanie SED_ERROR.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Kiedy węzły SED są uaktualniane bezpośrednio do OneFS 9.5 z wersji OneFS starszej niż 9.2, węzły nie uruchamiają się całkowicie, a dyski są wyświetlane w stanie SED_ERROR. isi_sed pokazuje niepowodzenie uwierzytelniania dysku:
example-1# /usr/bin/isi_hwtools/isi_sed drive da3
BŁĄD: Key Manager error: error=1=ISI_KM_INIT_FAILED (Błąd menedżera kluczy: błąd = 1 = ISI_KM_INIT_FAILED
OSTRZEŻENIE: Nie można otworzyć połączenia Menedżera kluczy: Brak połączenia z menedżerem kluczy
BŁĄD: Błąd menedżera kluczy: Klucz 5000C500CB360D98.current: error=34=SED_RESULT_NO_KM_CONNECTION
OSTRZEŻENIE: Próba uzyskania aktualnego klucza dysku nie zwraca połączenia z Menedżerem kluczy
BŁĄD: Błąd menedżera kluczy: Klucz 5000C500CB360D98.future: error=34=SED_RESULT_NO_KM_CONNECTION
OSTRZEŻENIE: Próba uzyskania zwrotu klucza dysku w przyszłości — brak połączenia z Menedżerem kluczy
BŁĄD: Błąd menedżera kluczy: Key 5000C500CB360D98.change: error=34=SED_RESULT_NO_KM_CONNECTION
OSTRZEŻENIE: Próba zmiany klucza dysku nie została zwrócona Bez połączenia z Menedżerem kluczy
Stan dysku: Kieszeń A0: WWN 5000c500cb360d98
Model napędu SEAGATE STMFSKF2CLAR4000, SN ZC0A00A0
Zgodność z FIPS: FIPS 140-2 (0x32), poziom 2 (0x32), H/W: STMFSKF2CLAR4000, F/W: BV01, moduł: Dyski samoszyfrujące Seagate Secure TCG Enterprise SSC FIPS 140
Dysk MSID z kluczem
Stan works exists
======= ======= ======= =============== ===============
Nieznany błąd — brak AUTH_FAILED AUTH_FAILED
Własność innego węzła
Uwaga: Przyszły klucz istnieje: Błąd, działa: Nieznany
Uwaga: Istnieje zmiana klucza: Błąd, działa: Nieznany
Kieszeń A0: Dev da3, SEAGATE STMFSKF2CLAR4000, SN ZC1E03Y3, WWN 5000c500cb360d98: drive_display:
Success isi_km_d.log pokazuje błędy sqlite:
023-05-05T12:22:20.188716-05:00 example-7 (id7) isi_km_d[36798]: [0x803309000]key_mgr: Błąd initprovider [SEDS] z błędem sqlite: Błąd programu Sqlite: Błąd logiki SQL (1) — nie udało się przygotować instrukcji: SELECT version, passphrase_mode, kmip_uid, kmip_index, kmip_host, kmip_port, kmip_meta, kmip_cacert, kmip_clientcert FROM seds_config WHERE id = ?'.
Cause
Zmiany dotyczące obsługi funkcji klucza KM w OneFS 9.5.0 zakładają, że istnieje tabela bazy danych magazynu kluczy, która została dodana w wersji 9.2.0. Jeśli klaster został uaktualniony z wersji starszej niż OneFS 9.2 bezpośrednio do OneFS 9.5, menedżer kluczy nie może poprawnie odczytać bazy danych magazynu kluczy, ponieważ brakuje danej tabeli.
Resolution
Aby zapobiec temu problemowi, klienci aktualizujący oneFS do wersji 9.5 z wersji OneFS starszej niż 9.2 powinni najpierw zaktualizować oneFS do pośredniej wersji OneFS 9.2 lub 9.4. Po zakończeniu tej aktualizacji klaster można bezpiecznie uaktualnić do OneFS 9.5.
Jeśli problem już wystąpił, a klaster znajduje się w stanie opisanym w sekcji symptomy, należy natychmiast skontaktować się z działem pomocy technicznej i odnieść się do tego artykułu.
Jeśli problem już wystąpił, a klaster znajduje się w stanie opisanym w sekcji symptomy, należy natychmiast skontaktować się z działem pomocy technicznej i odnieść się do tego artykułu.
Affected Products
Isilon A200, Isilon A2000, Isilon F800, Isilon F810, Isilon H400, Isilon H500, Isilon H5600, Isilon H600, Isilon HD400, Isilon NL410, Isilon S210, Isilon X210, Isilon X410, PowerScale Archive A300, PowerScale Archive A3000, PowerScale F200
, PowerScale F600, PowerScale F900, PowerScale Hybrid H700, PowerScale Hybrid H7000
...
Article Properties
Article Number: 000213188
Article Type: Solution
Last Modified: 22 Jun 2023
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.