PowerPath Management Appliance (PPMA): rpowermt commands stopped working post upgrade of PPMA 3.2 to 3.4 P01

Summary: PowerPath Management Appliance (PPMA): rpowermt commands stopped working post upgrade of PPMA 3.2 to 3.4 P01.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Running rpowermt commands kept on returning the following error for all the PowerPath/VE hosts:

ERROR: ELMC720: Unable to fetch token for communication. Verify the PPMA details provided and ensure that PPMA instance is running.



Note: rpowermt commands were working before the upgrade.

Cause

In this specific case, the user used the same password for "ppadmin" user as that of "root" user during the upgrade. And while attempted to run any rpowermt commands, it kept on erroring out with the above error ELMC720.

The root cause was not setting up the same password as that of "root" user. But something else which seemed to be environmental in the User's setup and could not be reproduced in our lab beds even after multiple trials.

Resolution

rpowermt commands could be successfully run post changing the "ppadmin" password.

Products

PowerPath Management Appliance
Article Properties
Article Number: 000211399
Article Type: Solution
Last Modified: 21 Jun 2023
Version:  3
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