Dell Unity: Configuración de DNS perdida durante NDU
Summary: Después de realizar una actualización de código en un dispositivo físico o VSA de Unity, se elimina el DNS de administración.
Symptoms
Se lanzó 4.0.1.8404134 SP1.2, con lo cual se resolvió el problema.
Después de la actualización del código, se eliminaron los ajustes de DNS configurados estáticamente para la red de administración y se borró el contenido del archivo /etc/resolv.conf . El usuario no recibe un correo electrónico sobre la finalización correcta de la actualización. Todos los servicios que requieren la resolución de nombres DNS (NTP, SMTP, etc.) no funcionan correctamente hasta que la configuración de DNS se vuelve a ingresar manualmente. Aparte de eso, el usuario no puede conectarse a la interfaz de usuario de Unisphere ni a la CLI de UEM mediante el nombre de dominio del sistema.
Cause
Actualmente, esto está afectando las actualizaciones que involucran las siguientes revisiones de código.
- 4.0.1.8194551 SP1
La actualización de código al producto 4.0.1.8194551 borra la configuración de DNS, si esta última se ingresó manualmente (Configuración -> Administración -> Servidores DNS: Administrar servidores de nombre de dominio:> configure manualmente la dirección del servidor DNS). Después de la actualización, el contenido del archivo /etc/resolv.conf no se restaura. Detiene la resolución del nombre DNS y elimina la información del nombre de dominio del sistema. A su vez, puede afectar los servicios de red, incluidos NTP y SMTP, y eliminar el nombre de dominio del sistema del certificado SSL de la conexión de administración.
Debido a la persistencia del problema de configuración que puede ocurrir después de la actualización al entorno operativo (OE) Unity 4.0.1.8194551, Dell Technologies decidió eliminar esta versión de Unity y UnityVSA de support.emc.com.
Está disponible una versión revisada del OE 4.0.1.8404134 Unity SP1.2.
Se sugiere que los clientes que planeaban actualizar a 4.0.1.8194551 esperaran para actualizar a la próxima versión.
Para los clientes que ya ejecutan 4.0.1.8194551, revise que las preferencias del servidor DNS estén configuradas correctamente en Unisphere > Settings > Management > DNS Server y actualícelas según sea necesario.
Comuníquese con el soporte de Dell Technologies si tiene preguntas: visite el soporte en línea de Dell Technologies en: https://www.dell.com/support/home. Después de iniciar sesión, busque Create a service request.
Resolution
La solución alternativa actual es volver a crear los ajustes de DNS en la configuración de administración.
Interfaz de usuario:
- Vaya al menú Configuración en la parte superior derecha
- Haga clic en la sección Management y, a continuación, en DNS Server
- Para DNS configurado manualmente, haga clic en Add y vuelva a agregar los servidores DNS originales.
- Haga clic en el botón "Apply" en la parte inferior del cuadro de diálogo.
- Vaya a: Sistema --> Servicio -->Tareas de servicio
- Seleccione "Reiniciar el software de administración" y, luego, presione "Ejecutar"
- Actualice la ventana del navegador. Es posible que tenga que esperar unos minutos para permitir que se inicie el software de administración.
- Si se le solicita, confirme la excepción de seguridad para esta conexión.
UEMCLI:
- Conectarse al sistema mediante la dirección IP.
- Para cada dirección DNS, ingrese el siguiente comando:
uemcli /net/dns/config set -nameServer <value>
- Luego, reinicie el software de administración mediante el comando que se muestra a continuación.
Nota: Se debe realizar desde la cuenta del administrador de servicios:
uemcli u service p <service password> /service/system restart
- Si se cambia el certificado de seguridad, acepte el nuevo certificado como de costumbre.
Después del último paso, puede volver a conectarse al sistema por su nombre.
Actualizar:
La versión más reciente de SP1 contiene la corrección para este problema 4.0.1.84.04134.