Dell Unity : Paramètres DNS perdus pendant la mise à niveau sans perturbation
Summary: Après avoir effectué une mise à niveau de code sur un Unity VSA ou une boîte physique, le DNS de gestion est supprimé.
Symptoms
La version 4.0.1.8404134 SP1.2 a été publiée et résout le problème.
Après la mise à niveau du code, les paramètres DNS configurés statiquement ont été supprimés pour le réseau de gestion. Le contenu du fichier /etc/resolv.conf est effacé. L’utilisateur ne reçoit pas d’e-mail l’informant de la réussite de la mise à niveau. Tous les services qui nécessitent une résolution de noms DNS (NTP, SMTP, etc.) ne fonctionnent pas correctement tant que les paramètres DNS ne sont pas saisis à la main. En dehors de cela, l’utilisateur ne peut pas se connecter à l’interface utilisateur Unisphere ou à l’interface de ligne de commande UEM à l’aide du nom de domaine système.
Cause
Cela a actuellement un impact sur les mises à niveau impliquant les révisions de code ci-dessous.
- 4.0.1.8194551 SP1
La mise à niveau du code vers la version 4.0.1.8194551 efface les paramètres DNS, s’ils ont été saisis manuellement (Paramètres -> Gestion -> Serveurs DNS : Gérer les serveurs de noms de domaine :> configurez manuellement l’adresse du serveur DNS). Après la mise à niveau, le contenu du fichier /etc/resolv.conf n’est pas restauré. Cela arrête la résolution du nom DNS et supprime les informations de nom de domaine du système. À son tour, cela peut affecter les services de mise en réseau, y compris NTP et SMTP, et supprimer le nom de domaine système du certificat SSL de connexion de gestion.
En raison d’un problème persistant de paramètres qui peut se produire après la mise à niveau vers l’environnement d’exploitation (OE) Unity 4.0.1.8194551, Dell Technologies a décidé de supprimer cette version de Unity et UnityVSA de support.emc.com.
Une version révisée de l’OE est disponible 4.0.1.8404134 Unity SP1.2.
Les clients qui prévoyaient une mise à niveau vers la version 4.0.1.8194551 sont invités à attendre avant d’effectuer la mise à niveau vers la prochaine version.
Pour les clients qui exécutent déjà la version 4.0.1.8194551, vérifiez que vos préférences de serveur DNS sont correctement définies sous Paramètres Unisphere > Serveur > DNS de gestion > et mettez à jour si nécessaire.
Si vous avez des questions, contactez le support Dell Technologies : rendez-vous sur le site de support en ligne Dell Technologies à l’adresse : https://www.dell.com/support/home. Une fois connecté, recherchez Créer une demande de service.
Resolution
La solution de contournement actuelle consiste à recréer les paramètres DNS dans la configuration de gestion.
Interface utilisateur :
- Accédez au menu Settings dans l’angle supérieur droit
- Cliquez sur la section Gestion, puis sur Serveur DNS
- Pour un DNS configuré manuellement, cliquez sur Ajouter et ajoutez à nouveau les serveurs DNS d’origine.
- Cliquez sur le bouton « Appliquer » en bas de la boîte de dialogue.
- Accédez à : Système --> Service -->Tâches de service
- Sélectionnez « Redémarrer le logiciel de gestion », puis appuyez sur « Exécuter »
- Actualisez la fenêtre du navigateur. Vous devrez peut-être attendre quelques minutes pour permettre au logiciel de gestion de démarrer.
- Si vous y êtes invité, confirmez l’exception de sécurité pour cette connexion.
UEMCLI :
- Connectez-vous au système à l’aide de l’adresse IP.
- Pour chaque adresse DNS, saisissez la commande suivante :
uemcli /net/dns/config set -nameServer <value>
- Redémarrez ensuite le logiciel de gestion à l’aide de la commande ci-dessous.
Remarque : Elle doit être effectuée à partir du compte administrateur du service :
uemcli u service p <service password> /service/system restart
- Si le certificat de sécurité est modifié, acceptez le nouveau certificat comme d’habitude.
Après la dernière étape, vous pouvez à nouveau vous connecter au système par son nom.
Mise à niveau :
La dernière version de SP1 contient le correctif pour ce problème 4.0.1.84.04134.