Dell Unity:DNS 設定在 NDU 期間遺失
Summary: 在 Unity VSA 或實體方塊上執行程式碼升級後,管理 DNS 隨即移除。
Symptoms
4.0.1.8404134 SP1.2 已發佈,可解決此問題。
程式碼升級後,管理網路的靜態設定 DNS 設定會移除,檔案 /etc/resolv.conf 的內容會遭到清除。使用者不會收到成功完成升級的電子郵件。在手動重新輸入 DNS 設定之前,所有需要 DNS 名稱解析的服務(NTP、SMTP 等)都無法正常工作。除此之外,使用者無法使用系統網域名稱連線至 Unisphere UI 或 UEM CLI。
Cause
這會影響涉及以下程式碼修訂版的升級。
- 4.0.1.8194551 SP1
程式碼升級至產品 4.0.1.8194551 會清除 DNS 設定(如果後者是手動輸入的 (設定 -> 管理 -> DNS 伺服器:管理網域名稱伺服器 -> 手動設定 DNS 伺服器位址)。升級後,不會還原檔案 /etc/resolv.conf 的內容。它會停止DNS名稱解析並從系統中刪除功能變數名稱資訊。反過來,它可能會影響網路服務,包括 NTP 和 SMTP,並從管理連接 SSL 證書中刪除系統功能變數名稱。
由於升級到 Unity 作業環境 (OE) 4.0.1.8194551 後可能會持續發生設定問題,Dell Technologies 決定從 support.emc.com 移除此 Unity 和 UnityVSA 版本。
提供修訂的 OE 版本 4.0.1.8404134 Unity SP1.2。
計劃升級到 4.0.1.8194551 的客戶建議等待升級到即將推出的版本。
若客戶已執行 4.0.1.8194551,請檢查在 Unisphere > 設定 > 管理 > DNS 伺服器下您的 DNS 伺服器偏好設定是否正確,並視需要更新。
如有任何疑問,請聯絡 Dell Technologies 支援部門,請前往 Dell Technologies 線上支援網站: https://www.dell.com/support/home。登入後,找到建立服務要求。
Resolution
目前的因應措施是在管理設定中重新建立 DNS 設定。
UI:
- 瀏覽至右上角的設定功能表
- 按一下管理區段,然後按一下 DNS 伺服器
- 若為手動配置的 DNS,請按一下新增,然後重新新增原始 DNS 伺服器。
- 按兩下對話框底部的「應用」 按鈕。
- 瀏覽至:系統 --> 服務 -->服務工作
- 選取「重新啟動管理軟體」,然後按下「執行」
- 重新整理瀏覽器視窗。您可能需要等待幾分鐘才能啟動管理軟體。
- 如果系統要求,請確認此連接的安全例外。
UEMCLI:
- 請透過 IP 位址連線至系統。
- 針對每個 DNS 位址,輸入下列命令:
uemcli /net/dns/config set -nameServer <value>
- 然後依照以下所示命令重新啟動管理軟體。
注意:此操作應從服務管理員帳戶執行:
uemcli u service p <service password> /service/system restart
- 如果安全證書已更改,請像往常一樣接受新證書。
完成最後一個步驟后,您可以再次按名稱連接到系統。
升級:
SP1 的最新版本包含此問題的修復程式 4.0.1.84.04134。