Dell Unity:NDU 期间 DNS 设置丢失
Summary: 在 Unity VSA 或物理机箱上执行代码升级后,将删除管理 DNS。
Symptoms
已发布 4.0.1.8404134 SP1.2,可解决此问题。
代码升级后,为管理网络删除了静态配置的 DNS 设置,文件 /etc/resolv.conf 的内容将被擦除。用户不会收到有关升级成功完成的电子邮件。在手动重新输入 DNS 设置之前,所有需要 DNS 名称解析的服务(NTP、SMTP 等)都无法正常工作。除此之外,用户无法使用系统域名连接到 Unisphere UI 或 UEM CLI。
Cause
这目前正在影响涉及以下代码修订的升级。
- 4.0.1.8194551 SP1
升级到产品 4.0.1.8194551 的代码将擦除 DNS 设置(如果后者是手动输入的,则为 Settings -> Management -> DNS Servers:管理域名服务器 —> 手动配置 DNS 服务器地址)。升级后, 文件 /etc/resolv.conf 的内容不会恢复。它将停止 DNS 名称解析,并从系统中删除域名信息。进而可能会影响网络服务(包括 NTP 和 SMTP),并从管理连接 SSL 证书中删除系统域名。
由于升级到 Unity Operating Environment (OE) 4.0.1.8194551 后可能仍然存在设置问题,因此 Dell Technologies 决定从 support.emc.com 中删除此 Unity 和 UnityVSA 版本。
修订的 OE 版本是 4.0.1.8404134 Unity SP1.2。
建议计划升级到 4.0.1.8194551 的客户等待升级到即将发布的版本。
对于已运行 4.0.1.8194551 的客户,请查看您的 DNS 服务器首选项是否在 Unisphere > 设置 > 管理 > DNS 服务器下正确设置,并根据需要进行更新。
如有任何疑问,请联系 Dell Technologies 支持 — 请访问 Dell Technologies 在线支持网站: https://www.dell.com/support/home。登录后,找到 Create a service request。
Resolution
当前的解决方法是在管理设置中重新创建 DNS 设置。
UI:
- 浏览至右上角的设置菜单
- 单击 Management部分,然后单击 DNS Server
- 对于手动配置的 DNS,请单击 Add并重新添加原始 DNS 服务器。
- 单击对话框底部的“应用”按钮。
- 浏览至:系统 --> 服务 --> 服务任务
- 选择“重新启动管理软件”,然后按“执行”
- 刷新浏览器窗口。您可能需要等待几分钟才能允许管理软件启动。
- 如果询问,请确认此连接的安全例外。
UEMCLI:
- 通过 IP 地址连接到系统。
- 对于每个 DNS 地址,输入以下命令:
uemcli /net/dns/config set -nameServer <value>
- 然后,使用下面所示的命令重新启动管理软件。
提醒:应从服务管理员帐户执行此作:
uemcli u service p <service password> /service/system restart
- 如果更改了安全证书,请照常接受新证书。
完成最后一步后,您可以再次按名称连接到系统。
升级:
最新版本的 SP1 包含此问题的修补程序 4.0.1.84.04134。