AppSync: Initialisierungsparameter mit "Komma" nicht akzeptiert
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Der Nutzer hat einen neuen Initialisierungsparameter hinzugefügt.
Beim Hinzufügen eines Initialisierungsparameters zu einem Job mit einem Komma in der Zeichenfolge wird er falsch formatiert. Die richtige Zeichenfolge lautet:
AUDIT_TRAIL=DB,EXTENDED
Nachdem der Job jedoch gespeichert wurde, wird der Teil "EXTENDED" in eine separate Zeile eingefügt.
AUDIT_TRAIL=DB,EXTENDED
Der DBA hat alle gängigen Escape-Zeichen ausprobiert, um das Komma erscheinen zu lassen (umgekehrter Schrägstrich, doppeltes Komma usw.).
Beim Hinzufügen eines Initialisierungsparameters zu einem Job mit einem Komma in der Zeichenfolge wird er falsch formatiert. Die richtige Zeichenfolge lautet:
AUDIT_TRAIL=DB,EXTENDED
Nachdem der Job jedoch gespeichert wurde, wird der Teil "EXTENDED" in eine separate Zeile eingefügt.
AUDIT_TRAIL=DB,EXTENDED
Der DBA hat alle gängigen Escape-Zeichen ausprobiert, um das Komma erscheinen zu lassen (umgekehrter Schrägstrich, doppeltes Komma usw.).
Cause
Dies ist ein einzigartiger Fall, in dem die Initialisierungsparameter je nach Anforderung separat in einer neuen Zeile angezeigt werden müssen. Das Problem hier bestand jedoch darin, dass die Benutzeroberfläche die einzelne Zeichenfolge, die der Server sendet, in eine neue Zeile geparst hat. Ursprünglich wurde das Kommatrennzeichen verwendet, um die Zeichenfolgen aufzuteilen und als neue Zeile einzufügen.
Resolution
Für dieses Problem gibt es zwar eine Lösung, zum Installieren eines Hotfix ist jedoch ein Mitarbeiter des technischen Supports von EMC erforderlich. Wenden Sie sich an das EMC Customer Support Center oder Ihren Servicemitarbeiter, um technische Unterstützung zu erhalten, und geben Sie diese Artikel-ID an.
Products
AppSyncArticle Properties
Article Number: 000064917
Article Type: Solution
Last Modified: 18 Sept 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.