Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Article Number: 000065433


NetWorker Management Console: Intermittently GST Service stop require multiple restart

Summary: Intermittently GST Service stop require multiple restart to log in

Article Content


Symptoms



Intermittently GST Service stop functioning require multiple restart to log in to the NMC

Cause

Inconstant NMC database, or intermittently NMC database access failing

GST log may show following errors
0 16/10/2016 2:36:15 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 10/16/16 02:36:15.xxxxxx The most recently called subfunction returned error 2.
0 16/10/2016 2:36:15 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 10/16/16 02:36:15.xxxxxx D:/views/nw/9.0.1/gst/modules/psm2/tsc_man_evnt.c(914): Internal error: ODBC problem.
0 16/10/2016 2:36:15 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 10/16/16 02:36:15.xxxxxx       ODBC environment handle:
0 16/10/2016 2:36:15 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 10/16/16 02:36:15.xxxxxx       ODBC database connection handle:
0 16/10/2016 2:36:15 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 10/16/16 02:36:15.xxxxxx       ODBC statement handle:
0 16/10/2016 2:36:15 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 10/16/16 02:36:15.xxxxxx The most recently called subfunction returned error 2.
0 16/10/2016 2:36:15 AM  1 5 0 xxxxxx test.lab.local gstd NSR notice 10/16/16 02:36:15.xxxxxx poll: ERROR, failed to store_fetch from database


0 27/02/2017 8:05:16 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 02/27/17 08:05:16.xxxxxx Out of memory.
0 27/02/2017 8:05:16 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 02/27/17 08:05:16.xxxxxx Could not add attribute 'poll_private'.
0 27/02/2017 8:05:16 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 02/27/17 08:05:16.xxxxxx Out of memory.
0 27/02/2017 8:05:16 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 02/27/17 08:05:16.xxxxxx The most recently called subfunction returned error 2.
0 27/02/2017 8:05:16 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 02/27/17 08:05:16.xxxxxx The most recently called subfunction returned error 2.
0 27/02/2017 8:05:16 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 02/27/17 08:05:16.xxxxxx The most recently called subfunction returned error 2.
0 27/02/2017 8:05:16 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 02/27/17 08:05:16.xxxxxx The most recently called subfunction returned error 2.
0 27/02/2017 8:05:16 AM  1 5 0 xxxxxxxx test.lab.local gstd NSR notice 02/27/17 08:05:16.xxxxxx end of processing msg 'psm/fetch' rescode 2    reason: 'Out of memory.'

Resolution

Installing NMC on another host to verify reinstall resolve the problem.

Procedure to reinstall NMC server
  • Uninstall NMC (NetWorker Management Console) - Do not uninstall Networker server software
  • Rename NMC folder ('Management' folder)
  • Install NMC (NetWorker Management Console) again and configured.
If there are recent good NMC database backup available, restoring NMC database may help.

Article Properties


Affected Product

NetWorker Management Console

Product

NetWorker Management Console

Last Published Date

20 Nov 2020

Version

2

Article Type

Solution