VxRail: Nie można dodać użytkownika kontrolera iDRAC w interfejsie użytkownika wtyczki VxRail.

Summary: Jak naprawić błąd dodawania użytkownika iDRAC w vCenter (iDRAC wersja >= 4.22.00.201)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Dodanie nowego użytkownika Integrated Dell Remote Access Controller (iDRAC) w interfejsie użytkownika vCenter kończy się niepowodzeniem z komunikatem o błędzie "Running script error: Script output fail: 400 Client Error...."

Przykładowy zrzut ekranu po niepowodzeniu dodawania użytkownika o nazwie "użytkownik" i uprawnieniach administratora do identyfikatora 4:

Zrzut ekranu przedstawiający błąd podczas dodawania użytkownika iDRAC 

Gdy dodanie użytkownika iDRAC nie powiedzie się, zaloguj się do interfejsu sieciowego iDRAC, nowy użytkownik zostanie utworzony, ale wyłączony, a jego rola to "none.

Przykładowy zrzut ekranu na karcie > ustawień > interfejsu użytkownika > kontrolera iDRAC Użytkownicy lokalni:

Zrzut ekranu użytkownika przedstawiający brak 

W graficznym interfejsie użytkownika wtyczki VxRail użytkownik jest dodawany, ale jego uprawnienie jest ustawione na "idrac.user.role.NONE".

Przykładowy zrzut ekranu hostów i klastrów > vCenter > Węzeł > klastra > VxRail DataCenter > Konfiguracja > użytkowników konfiguracji VxRail > iDRAC>:

Zrzut ekranu z vSphere przedstawiający rolę użytkownika brak 

Ten problem występuje podczas dodawania użytkownika iDRAC w interfejsie użytkownika wtyczki VxRail, a podane hasło nie spełnia potrzeb kontrolera iDRAC.

Cause

Ten problem występuje, ponieważ hasło użyte do utworzenia konta nie spełnia wymogu złożoności hasła z kontrolera iDRAC.

Na przykład począwszy od kontrolera iDRAC w wersji 4.22.00.201 wymóg złożoności hasła jest bardziej rygorystyczny niż w poprzedniej wersji.

Resolution

Wykonaj następujące czynności, aby naprawić częściowo dodanego użytkownika w kontrolerze iDRAC:

  1. Zaloguj się do interfejsu sieciowego kontrolera iDRAC jako użytkownik root lub dowolny użytkownik z uprawnieniami administratora
  2. Przeprowadź reset kontrolera iDRAC (iDRAC > Maintenance > Diagnostics > Reset iDRAC), aby upewnić się, że cała konfiguracja wyświetlana w nawigatorze iDRAC jest poprawna.
  3. Edytuj nowo dodanego użytkownika w kontrolerze iDRAC, zmieniaj hasło, aż będzie mógł spełnić ograniczenie, i upewnij się, że wszystkie znaki x na poniższym obrazku zostały rozwiązane. Wymagania mogą się różnić w zależności od wersji. 
Zrzut ekranu przedstawiający reguły haseł
  1. Zmień rolę użytkownika na Administrator i zapisz.
Ustaw rolę na administrator
  1. Sprawdź rolę użytkownika w kontrolerze iDRAC i vCenter i upewnij się, że uprawnienia użytkownika zostały zmienione na "Administrator":
Zrzut ekranu przedstawiający rolę użytkownika ustawioną na administratora
  1.       Jeśli powyższy proces nie rozwiąże problemu, skontaktuj się z działem pomocy technicznej firmy Dell, aby uzyskać inne obejścia problemu.

Additional Information

  • Domyślny identyfikator nowego użytkownika kontrolera iDRAC jest wybierany automatycznie i jest to identyfikator nieużywany.
Zrzut ekranu przedstawiający identyfikator użytkownika
  • Przed dodaniem nowej nazwy użytkownika w vCenter sprawdź, czy nowa nazwa użytkownika nie jest używana.

Zapoznaj się z niniejszym filmem:

Products

VxRail, VxRail Appliance Series, VxRail Software
Article Properties
Article Number: 000180902
Article Type: Solution
Last Modified: 20 Feb 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.