VxRail. Не удалось добавить пользователя iDRAC в пользовательский интерфейс подключаемого модуля VxRail.
Summary: Как восстановить после сбоя добавления пользователя iDRAC в vCenter (iDRAC версии >= 4.22.00.201)
Symptoms
Добавление нового пользователя Integrated Dell Remote Access Controller (iDRAC) в пользовательский интерфейс vCenter завершается сбоем с сообщением об ошибке "Running script error: Script output fail: 400 Client Error...."
Пример снимка экрана, когда не удалось добавить пользователя с именем user и привилегиями администратора в ID 4:
Если добавить пользователя iDRAC не удается, выполните вход в веб-интерфейс iDRAC, новый пользователь будет создан, но отключится, а роль пользователя будет «none».
Пример снимка экрана на вкладке > «Пользователи в настройках > пользовательского интерфейса > iDRAC» Локальные пользователи:
В графическом интерфейсе пользователя подключаемого модуля VxRail пользователь добавляется, но для его прав присваивается значение «idrac.user.role.NONE».
Пример снимка экрана для хостов и кластеров > vCenter > Datacenter > Узел > кластера > VxRail Настройка > конфигурации VxRail > iDRAC Пользователи конфигурации>:
Эта проблема возникает при добавлении пользователя iDRAC в пользовательском интерфейсе подключаемого модуля VxRail, когда указанный пароль не соответствует требованиям iDRAC.
Cause
Например, начиная с версии iDRAC 4.22.00.201, требования к сложности пароля стали более строгими, чем в предыдущей версии.
Resolution
Чтобы исправить частично добавленного пользователя в iDRAC, выполните следующие действия.
- Войдите в веб-интерфейс iDRAC в качестве пользователя root или любого пользователя с привилегиями администратора.
- Выполните сброс iDRAC (iDRAC > Maintenance > Diagnostics > Reset iDRAC), чтобы убедиться в правильности всей конфигурации, отображаемой в iDRAC Navigator.
- Отредактируйте только что добавленного пользователя в iDRAC, измените пароль, чтобы он соответствовал ограничениям, и убедитесь, что все x на рисунке ниже устранены. Требования могут различаться в зависимости от версии.
- Измените роль пользователя на Administrator и сохраните роль.
- Перепроверьте роль пользователя в iDRAC и vCenter и убедитесь, что права пользователя изменены на «Администратор».
- Если описанные выше действия не помогли решить проблему, обратитесь в службу поддержки Dell за другими временными решениями.
Additional Information
- Идентификатор по умолчанию для нового пользователя iDRAC выбирается автоматически, и это неиспользуемый идентификатор.
- Прежде чем добавить нового пользователя в vCenter, убедитесь, что новое имя пользователя не используется.
См. видео: