VxRail. Не удалось добавить пользователя iDRAC в пользовательский интерфейс подключаемого модуля VxRail.

Summary: Как восстановить после сбоя добавления пользователя iDRAC в vCenter (iDRAC версии >= 4.22.00.201)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Добавление нового пользователя Integrated Dell Remote Access Controller (iDRAC) в пользовательский интерфейс vCenter завершается сбоем с сообщением об ошибке "Running script error: Script output fail: 400 Client Error...."

Пример снимка экрана, когда не удалось добавить пользователя с именем user и привилегиями администратора в ID 4:

Снимок экрана ошибки добавления пользователя iDRAC. 

Если добавить пользователя iDRAC не удается, выполните вход в веб-интерфейс iDRAC, новый пользователь будет создан, но отключится, а роль пользователя будет «none».

Пример снимка экрана на вкладке > «Пользователи в настройках > пользовательского интерфейса > iDRAC» Локальные пользователи:

Снимок экрана, на котором пользователь не отображается 

В графическом интерфейсе пользователя подключаемого модуля VxRail пользователь добавляется, но для его прав присваивается значение «idrac.user.role.NONE».

Пример снимка экрана для хостов и кластеров > vCenter > Datacenter > Узел > кластера > VxRail Настройка > конфигурации VxRail > iDRAC Пользователи конфигурации>:

Снимок экрана из vSphere, показывающий роль пользователя «Нет» 

Эта проблема возникает при добавлении пользователя iDRAC в пользовательском интерфейсе подключаемого модуля VxRail, когда указанный пароль не соответствует требованиям iDRAC.

Cause

Эта проблема возникает из-за того, что пароль, используемый для создания учетной записи, не соответствует требованиям iDRAC по сложности пароля.

Например, начиная с версии iDRAC 4.22.00.201, требования к сложности пароля стали более строгими, чем в предыдущей версии.

Resolution

Чтобы исправить частично добавленного пользователя в iDRAC, выполните следующие действия.

  1. Войдите в веб-интерфейс iDRAC в качестве пользователя root или любого пользователя с привилегиями администратора.
  2. Выполните сброс iDRAC (iDRAC > Maintenance > Diagnostics > Reset iDRAC), чтобы убедиться в правильности всей конфигурации, отображаемой в iDRAC Navigator.
  3. Отредактируйте только что добавленного пользователя в iDRAC, измените пароль, чтобы он соответствовал ограничениям, и убедитесь, что все x на рисунке ниже устранены. Требования могут различаться в зависимости от версии. 
Снимок экрана с правилами паролей
  1. Измените роль пользователя на Administrator и сохраните роль.
Установите роль администратора
  1. Перепроверьте роль пользователя в iDRAC и vCenter и убедитесь, что права пользователя изменены на «Администратор».
Снимок экрана, показывающий роль администратора
  1.       Если описанные выше действия не помогли решить проблему, обратитесь в службу поддержки Dell за другими временными решениями.

Additional Information

  • Идентификатор по умолчанию для нового пользователя iDRAC выбирается автоматически, и это неиспользуемый идентификатор.
Снимок экрана с идентификатором пользователя
  • Прежде чем добавить нового пользователя в vCenter, убедитесь, что новое имя пользователя не используется.

См. видео:

Products

VxRail, VxRail Appliance Series, VxRail Software
Article Properties
Article Number: 000180902
Article Type: Solution
Last Modified: 20 Feb 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.