VxRail: Falha ao adicionar o usuário do iDRAC na interface do usuário do plug-in do VxRail.
Summary: Como recuperar uma falha na adição de um usuário do iDRAC no vCenter (versão do iDRAC >= 4.22.00.201)
Symptoms
Falha na adição de um novo usuário do Integrated Dell Remote Access Controller (iDRAC) na interface do usuário do vCenter com mensagem de erro "Running script error: Script output fail: 400 Client Error...."
Captura de tela de amostra quando falha ao adicionar um usuário com o nome "user" e privilégio de administrador ao ID 4:
Quando a adição de usuário do iDRAC falha, faça login na IU da Web do iDRAC, o novo usuário é criado, mas desabilitado, e a função de usuário é "none".
Captura de tela de exemplo na guia > Usuários locais das configurações da > interface do usuário > do iDRAC: usuários locais:
Na GUI do plug-in do VxRail, o usuário é adicionado, mas o privilégio é definido como "idrac.user.role.NONE".
Captura de tela de exemplo em hosts e clusters do vCenter > Nó > do cluster > do VxRail do Datacenter > Configurar > usuários da > configuração > do iDRAC do VxRail>:
Esse problema ocorre ao adicionar um usuário do iDRAC na interface do usuário do plug-in do VxRail e a senha fornecida não atende às necessidades do iDRAC.
Cause
Por exemplo, a partir da versão 4.22.00.201 do iDRAC, o requisito de complexidade da senha é mais rigoroso do que na versão anterior.
Resolution
Use as seguintes etapas para corrigir o usuário parcialmente adicionado no iDRAC:
- Faça login na IU da Web do iDRAC com o usuário root ou qualquer usuário com privilégio de administrador
- Faça uma reinicialização do iDRAC (iDRAC > Maintenance > Diagnostics Reset iDRAC) para garantir que todas as configurações exibidas >no iDRAC Navigator estejam corretas.
- Edite o usuário recém-adicionado no iDRAC, altere a senha até que ela possa atender à limitação e certifique-se de que todos os x na imagem abaixo sejam resolvidos. Os requisitos podem variar de uma versão para outra.
- Altere a User Role para Administrator e salve.
- Verifique novamente a função de usuário no iDRAC e no vCenter, certifique-se de que o privilégio de usuário tenha sido alterado para "Administrator":
- Se o processo acima não resolver o problema, entre em contato com o Suporte Dell para obter outras soluções temporárias.
Additional Information
- O ID padrão de um novo usuário do iDRAC é escolhido automaticamente, e é um ID não utilizado.
- Verifique se o novo nome de usuário não está em uso antes de adicionar o novo usuário ao vCenter.
Consulte este vídeo: