Deployment KB: Unable to power on the VM on ESXi host in the CR Vault

Summary: During VM restore inside the cyber vault, VM restore failed to power on.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

In the /var/log/vmware.log file, similar entries to the below are seen:    
Unable to create virtual scsi0:0.filters="esx_splitter",
Failed to attach filter scsi0:0.filters="esx_splitter": Not found.
error.jpg
Note: The log excerpts are examples. Date, time, and environmental variables may vary depending on the environment.
 

Cause

Production VM protected using RP4VM may cause issues after restore inside the vault. 

This issue usually occurs if there is a splitter installed on the source ESXi host which is not present on the destination ESXi host.

Resolution

To resolve this issue, follow the steps below:     
  1. Connect to the ESXi host the virtual machine is on using SSH and root credentials
  2. Navigate to the virtual machines .vmx file using this command:      
cd /vmfs/volumes/datastore/virtual_machine_folder/
  1. Open the .vmx file with a text editor: vi virtual_machine.vmx
  2. Add a # before any filters that contain scsi0:0.filters="esx_splitter"
  3. Save the changes and exit the text editor.
  4. Power on the virtual machine.

Affected Products

Avamar, Cyber Recovery Series, VMware ESXi 6.x

Products

VMware ESXi 6.5.X, VMware ESXi 6.7.X, VMware ESXi 7.x
Article Properties
Article Number: 000183528
Article Type: Solution
Last Modified: 11 Aug 2022
Version:  6
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