Isilon: AD-Nutzer SSH zum Cluster ohne Standardstammverzeichnis kann die automatische Vervollständigung in SSH nicht mit der Registerkarte "Autovervollständigung" ausführen
Summary: Bei einem Systemadministrator, der mit Active Directory-Anmeldedaten angemeldet ist, ohne dass ein Stammverzeichnis erstellt wurde, kann es zu Problemen kommen, dass Befehle nicht automatisch abgeschlossen werden, wenn die Schaltfläche "Tab" gedrückt wird. ...
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Symptoms
AD-Nutzer SSH zu einem Cluster ohne Standardstammverzeichnis kann die automatische Vervollständigung in SSH nicht mit der Registerkarte "Autovervollständigung" durchführen.
Symptome 1)
Wenn NutzerInnen mit AD-Zugangsdaten bei Isilon angemeldet sind, wird die folgende Meldung angezeigt
ODER-Symptome
2)
Die Shell ist standardmäßig auf die Verwendung von /bin/bash eingestellt.
Symptome 1)
Wenn NutzerInnen mit AD-Zugangsdaten bei Isilon angemeldet sind, wird die folgende Meldung angezeigt
Could not chdir to home directory /ifs/home/DIRECTORY/ADUSERNAME: No such file or directory
ODER-Symptome
2)
Die Shell ist standardmäßig auf die Verwendung von /bin/bash eingestellt.
FreeCandy-1# isi auth users view 'MAINDOMAIN\ADUSERID' | grep Shell Shell: /bin/bash
Cause
Symptome 1) Aufgrund fehlender zshrc-Datei im Stammverzeichnis
Resolution
Lösung von Symptomen 1)
1) Erstellen Sie ein neues Home-Verzeichnis für diese/n spezifische NutzerIn. # mkdir /ifs/home/DIRECTORY/ADUSERNAME
2) Kopieren Sie die zshrc-Datei vom Stammverzeichnis in das Benutzerverzeichnis. # cp /root/.zshrc /ifs/home/DIRECTORY/ADUSERNAME
3) ssh aktualisieren # exec zsh
Symptome 2 Lösung)
1) Ändern des loginShell-Attributs auf der Active Directory-Seite
2) Leeren des Authentifizierungscaches auf Isilon # isi auth cache flush --all
1) Erstellen Sie ein neues Home-Verzeichnis für diese/n spezifische NutzerIn. # mkdir /ifs/home/DIRECTORY/ADUSERNAME
2) Kopieren Sie die zshrc-Datei vom Stammverzeichnis in das Benutzerverzeichnis. # cp /root/.zshrc /ifs/home/DIRECTORY/ADUSERNAME
3) ssh aktualisieren # exec zsh
Symptome 2 Lösung)
1) Ändern des loginShell-Attributs auf der Active Directory-Seite
2) Leeren des Authentifizierungscaches auf Isilon # isi auth cache flush --all
Affected Products
Isilon, PowerScale OneFSArticle Properties
Article Number: 000195742
Article Type: Solution
Last Modified: 28 Jun 2023
Version: 4
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