Isilon: AD-käyttäjä SSH-yhteys klusteriin ilman oletuskotihakemistoa ei voi siirtyä välilehdellä Automaattinen täydennys SSH:ssa
Summary: Järjestelmän ylläpitäjä, joka on kirjautunut Active Directory -tunnuksilla luomatta kotihakemistoaan, saattaa kohdata ongelman, kun komentoja ei suoriteta automaattisesti, kun painat sarkainpainiketta. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
AD-käyttäjä SSH-yhteys klusteriin ilman oletuskotihakemistoa ei voi siirtyä SSH-komennolla automaattiseen täydennystoimintoon.
oireet 1)
Kun käyttäjä on kirjautunut Isiloniin AD-tunnistetiedoilla, alla oleva ilmoitus tulee näkyviin
TAI
oireet 2)
Shellin oletusarvo on /bin/bash
oireet 1)
Kun käyttäjä on kirjautunut Isiloniin AD-tunnistetiedoilla, alla oleva ilmoitus tulee näkyviin
Could not chdir to home directory /ifs/home/DIRECTORY/ADUSERNAME: No such file or directory
TAI
oireet 2)
Shellin oletusarvo on /bin/bash
FreeCandy-1# isi auth users view 'MAINDOMAIN\ADUSERID' | grep Shell Shell: /bin/bash
Cause
oireet 1) Koska zShrc-tiedosto puuttuu kotihakemistosta
Resolution
Oireet 1 resoluutio)
1) Luo uusi kotihakemisto kyseiselle käyttäjälle. # mkdir /ifs/home/DIRECTORY/ADUSERNAME
2) Kopioi zshrc-tiedosto juuresta käyttäjän hakemistoon. # cp /root/.zshrc /ifs/home/DIRECTORY/ADUSERNAME
3) päivitä ssh # exec zsh
Oireet 2 resoluutio)
1) Muokkaa loginShell-attribuuttia Active Directory -puolella
2) Tyhjennä todennusvälimuisti Isilonissa # isi auth cache flush --all
1) Luo uusi kotihakemisto kyseiselle käyttäjälle. # mkdir /ifs/home/DIRECTORY/ADUSERNAME
2) Kopioi zshrc-tiedosto juuresta käyttäjän hakemistoon. # cp /root/.zshrc /ifs/home/DIRECTORY/ADUSERNAME
3) päivitä ssh # exec zsh
Oireet 2 resoluutio)
1) Muokkaa loginShell-attribuuttia Active Directory -puolella
2) Tyhjennä todennusvälimuisti Isilonissa # isi auth cache flush --all
Affected Products
Isilon, PowerScale OneFSArticle Properties
Article Number: 000195742
Article Type: Solution
Last Modified: 28 Jun 2023
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.