NetWorker: Gjenoppretting av Azure VM Snapshot mislykkes «kildebloben tilhører ikke samme område som disken»

Summary: NetWorker Azure Virtual Machine (VM) Snapshot-gjenoppretting mislykkes, og rapporterer at kildeblobben ikke tilhører samme område som disken.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Virtuelle Azure-maskiner er beskyttet ved hjelp av NetWorker Azure VM snapshot-beskyttelse.
En gjenoppretting av et Azure VM-øyeblikksbilde mislykkes med følgende feil i en feilsøkingslogg 7 (D7):

208119:nsrazure_recover: Error from url 'https://management.azure.com/subscriptions/SUBSRIPTION_ID/resourceGroups/RESOURCE_GROUP_NAME/providers/Microsoft.Compute/disks/VM-NAME_OsDisk_JOB-NAME_JOBID_TIME-STAMP?api-version=2021-12-01': Response Code: 400 Response Data: {
  "error": {
    "code": "BadRequest",
    "message": "The source blob https://STORAGE-ACCOUNT-NAME.blob.core.windows.net/CONTAINER-NAME/VM-NAME_OsDisk_JOB-NAME_JOBID_TIME-STAMP does not belong to the same region as the disk."
  }
}
..
MM/DD/YY HH:mm:SS nsrazure_recover-D7 restoreDiskFromBlob failed for payload '{
  "location": "REGION-NAME",
  "properties": {
    ...
    },
    "creationData": {
      "createOption": "Import",
      "sourceUri": https://STORAGE-ACCOUNT-NAME.blob.core.windows.net/CONTAINER-NAME/VM-NAME_OsDisk_JOB-NAME_JOBID_TIME-STAMP,
      "storageAccountId": "/subscriptions/SUBSCRIPTION-ID/resourceGroups/RESOURCE-GROUP-NAME/providers/Microsoft.Storage/storageAccounts/STORAGE-ACCOUNT-NAME"
    },
    "diskSizeGB": SIZE
  }
}'
MM/DD/YY HH:mm:SS nsrazure_recover-D6 restoreDiskFromBlob: end
207541:nsrazure_recover: Unable to start recover session for subscription 'SUBSCRIPTION-NAME', resource group 'RESOURCE-GROUP-NAME', storage account 'STORAGE-ACCOUNT-NAME'

Cause

Måldiskplasseringen som er valgt i gjenopprettingen, er i et annet Azure-område enn Azure-blob-lagringskontoen. Gjenopprettingsmålet som brukes, er for eksempel southcentralus; Azure-lagringskontoen som er angitt i gjenopprettingen, befinner seg imidlertid i eastus2.

Kildeblobben og måladministrert disk må være i samme område.

Resolution

  1. Logg på Azure-portalen.
  2. Naviger til lagringskontoen som ble brukt under gjenopprettingen. https://portal.azure.com/#browse/Microsoft.Storage%2FStorageAccounts Denne hyperkoblingen tar deg til et nettsted utenfor Dell Technologies.
  3. Fra Oversikt-fanen for lagringskontoen merker du av for Plassering. Hvis lagringskontoens plassering ikke samsvarer med måldiskplasseringen, kan du identifisere eller opprette en lagringskonto i samme Azure-område. Eksempel:

Azure Storage-konto

MERK: Lagringskontoen må tilhøre ressursgruppen VM-en gjenopprettes til.
  1. Utfør Azure-gjenopprettingen på nytt ved hjelp av Azure-lagringskontoplasseringen som samsvarer med måldiskplasseringen:

Gjenopprett navn på lagringskonto

Additional Information

Dette er en begrensning i Azure. Når du importerer via Azure-portalen, må du velge et Azure-destinasjonsområde som er tilgjengelig for lagringskontoen. Områder som ikke er tilknyttet lagringskontoen, kan ikke velges.
Se: Opplæringen: Importere data til Blob Storage med Azure-import-/eksporttjenesten Denne hyperkoblingen tar deg til et nettsted utenfor Dell Technologies.

 

Veiledningen for integrering av NetWorker Azure VM Snapshot angir følgende for alternativene for gjenoppretting:

-L  Spesifiserer området for den opprettede virtuelle maskinen. Dette alternativet er avledet fra informasjonen som samles inn under sikkerhetskopieringen.

Siden det ikke er noe alternativ i gjenopprettingsgrensesnittet, avledes målområdet fra sikkerhetskopien.

Alle NetWorker-veiledningene er tilgjengelige gjennom: https://www.dell.com/support/product-details/product/networker/docs

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000339191
Article Type: Solution
Last Modified: 02 Jul 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.