NetWorker: Återställningen av ögonblicksbilder av virtuella Azure-datorer misslyckas "källbloben tillhör inte samma region som disken"

Summary: Återställningen av ögonblicksbilden av NetWorker Azure Virtual Machine (VM) misslyckas och rapporterar att källbloben inte tillhör samma region som disken.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Virtuella Azure-datorer skyddas med hjälp av NetWorker Azure VM-ögonblicksbildsskydd.
En återställning av en ögonblicksbild av en virtuell Azure-dator misslyckas med följande fel i en återställningslogg för felsökning 7 (D7):

208119:nsrazure_recover: Error from url 'https://management.azure.com/subscriptions/SUBSRIPTION_ID/resourceGroups/RESOURCE_GROUP_NAME/providers/Microsoft.Compute/disks/VM-NAME_OsDisk_JOB-NAME_JOBID_TIME-STAMP?api-version=2021-12-01': Response Code: 400 Response Data: {
  "error": {
    "code": "BadRequest",
    "message": "The source blob https://STORAGE-ACCOUNT-NAME.blob.core.windows.net/CONTAINER-NAME/VM-NAME_OsDisk_JOB-NAME_JOBID_TIME-STAMP does not belong to the same region as the disk."
  }
}
..
MM/DD/YY HH:mm:SS nsrazure_recover-D7 restoreDiskFromBlob failed for payload '{
  "location": "REGION-NAME",
  "properties": {
    ...
    },
    "creationData": {
      "createOption": "Import",
      "sourceUri": https://STORAGE-ACCOUNT-NAME.blob.core.windows.net/CONTAINER-NAME/VM-NAME_OsDisk_JOB-NAME_JOBID_TIME-STAMP,
      "storageAccountId": "/subscriptions/SUBSCRIPTION-ID/resourceGroups/RESOURCE-GROUP-NAME/providers/Microsoft.Storage/storageAccounts/STORAGE-ACCOUNT-NAME"
    },
    "diskSizeGB": SIZE
  }
}'
MM/DD/YY HH:mm:SS nsrazure_recover-D6 restoreDiskFromBlob: end
207541:nsrazure_recover: Unable to start recover session for subscription 'SUBSCRIPTION-NAME', resource group 'RESOURCE-GROUP-NAME', storage account 'STORAGE-ACCOUNT-NAME'

Cause

Måldiskplatsen som valts i återställningen finns i en annan Azure-region än Azure Blob Storage-kontot. Återställningsmålet som används är till exempel southcentralus; Det Azure Storage-konto som anges i återställningen finns dock i eastus2. – Herr talman,

Källbloben och den hanterade måldisken måste finnas i samma region.

Resolution

  1. Logga in på Azure-portalen.
  2. Gå till det lagringskonto som användes under återställningen. https://portal.azure.com/#browse/Microsoft.Storage%2FStorageAccounts Den här hyperlänken tar dig till en webbplats utanför Dell Technologies.
  3. På fliken Översikt i lagringskontot kontrollerar du platsen. Om lagringskontots plats inte matchar måldiskplatsen identifierar eller skapar du ett lagringskonto inom samma Azure-region. Till exempel:

Azure Storage-konto

Obs! Lagringskontot måste tillhöra den resursgrupp som den virtuella datorn återställs till.
  1. Utför Azure-återställningen igen med hjälp av den plats för Azure Storage-kontot som matchar måldiskplatsen:

Återställa lagringskontots namn

Additional Information

Det här är en begränsning i Azure. När du importerar via Azure Portal måste du välja en Azure-målregion som är tillgänglig för lagringskontot. Det går inte att välja regioner som inte är associerade med lagringskontot.
Se: Handledning: Importera data till Blob Storage med Azure Import/Export-tjänsten Den här hyperlänken tar dig till en webbplats utanför Dell Technologies.

 

NetWorker Azure VM Snapshot Integration Guide anger följande för kommandoradsalternativen för återställning:

-L  Anger regionen för den skapade virtuella datorn. Det här alternativet härleds från den information som samlas in under säkerhetskopieringen.

Eftersom det inte finns något alternativ i återställningsgränssnittet härleds målregionen från säkerhetskopian.

Alla NetWorker-manualer är tillgängliga via: https://www.dell.com/support/product-details/product/networker/docs

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000339191
Article Type: Solution
Last Modified: 02 Jul 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.